sticking brake caliper

Discussion in 'Wheels' started by Eddy1, Apr 4, 2010.

  1. Eddy1

    Eddy1 Member

    45
    16
    0
    pulled caliper off and cleaned with brake clean and shoe lace. after cleaning several times caliper seems to work fine. but now i only have about one half inch play at brake lever. any suggestions on what to look for would be appriciated. thanx
     
  2. Adamal47

    Adamal47 Active Member

    301
    0
    3
    are both inside and outside pads seated correctly?
     
  3. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    Also check that the stainless still spring clip that centers the pads in the caliper is installed correctly (it is hard to see how it clamps them in) and also make sure the you lubricated the ungrooved or bent pin. You should see very little if any exposed piston as the new pads are pretty thick and the caliper is full wide open. You may have to bleed and pump them several times to get everything lined up. Retest and then bungee the lever closed, overnight and then release slowly and pump several times, should be better. Make sure you used the right fluid DOT rating marked on the M/C cover.
     
  4. Jonas

    Jonas Junior Member

    408
    0
    2
    Did you install new pads? When you say ONLY 1/2". Is that less then you had before cleaning. If it is, that would be the results of having clean pistons. You may have just been use to a soft brake pull.
     
  5. Eddy1

    Eddy1 Member

    45
    16
    0
    Everything seems to be where it's should be. i'll have to check everything out again & try the bungie cord. Hey guys thanx for replies.