stator plug leaking...

Discussion in 'Touring Models' started by Benmedley, Nov 20, 2011.

  1. Benmedley

    Benmedley Member

    25
    0
    0
    I have a 2004 Road King and have recently noticed the stator plug is leaking a little primary fluid-just a drop or 2 on the ground after a short ride.I put new crank seal in and replaced the stator maybe 4 or 5 months ago.The oil from the engine isn't overfilling the primary.Is there a way to fix this problem without replacing the stator I just put in? Thanks,Ben Medley


    2004 FLHR
    S&S 510 gear drive cams
    Mikuni HSR 42
    Thunderheader
    Twin Tec Ignition
    S&S single bore dual runner AC
    Screamin Eagle Hybrid Billet Cam support plate and oil pump
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    398
    Yep, un plug it and find an o ring that fits under the plug, plug it back in and ride it
     
  3. Benmedley

    Benmedley Member

    25
    0
    0
    you have done this before with success?
     
  4. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    398
    Yep, get it good and clean first:s
     
  5. Benmedley

    Benmedley Member

    25
    0
    0
    what did you use to clean it with and did you use any silicone on the plug and oring?
     
  6. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    398
    Brake clean and Harley Davidson Community you may use a bit of RTV silicone around the plug also
     
  7. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,630
    68
    99