Starts but runs irregulary or misses

Discussion in 'Dyna Models' started by rjsogard, Oct 20, 2009.

  1. rjsogard

    rjsogard Member

    76
    16
    0
    Hi all rich with a 06 WG problem.
    Well this morning i went to start my bike and let it warm up it started but has a low idle then it stalled so i started it again after a min it stalled again. after i started again i revved the engine at a constant speed it seem to be fine so i rode it around the block I felt a misse fire but NO back fire threw exhaust. my engine ck light came on and the batt light came on.
    so i limp it to my house and had no time this morning to work on it untill this after noon any ideas.

    I did fill it up with shell 91 octane 4 gals 20 miles ago
    stock battery
    also how do i test the reg and alt and stator with multi meter thanks rich.
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
  3. rjsogard

    rjsogard Member

    76
    16
    0
    Hey thanks i will try that i am new to this site i will post my findings
     
  4. wildspirit97

    wildspirit97 Senior Member

    1,088
    46
    0
    you said it's the stock battery on an 06. I don't know where you live but around here the temps are dropping and chances are your battery may not be up to par especially if you don't use a battery tender.

    Good luck, hopefully its just the battery:s
     
  5. rjsogard

    rjsogard Member

    76
    16
    0
    hello all well i just ck my batt it good just low at 12.35 but when i start it up at idle it drops at 12.11. so its not charging the batt i guess its the alt /reg /stator be the problem. any other choices? before i send it to the stealer its under warrenty ESP.
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
  7. rjsogard

    rjsogard Member

    76
    16
    0
    thanks glider will ESP COVER THIS? ALT AND STATOR REPLACEMENT and other damage ie clutch componets thanks again YOU ARE THE MAN!!!!:cheers
     
  8. glider

    glider Veteran Member

    25,464
    108
    44
    No reason why they shouldn't cover the stator replacement unless it is specifically mentioned that they don't cover it.
     
  9. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Read your warranty papers it should be covered I had a 92 and a 97 Bagger repaired with the same problems extended warranty covered all but 50 deductable good luck
     
  10. rjsogard

    rjsogard Member

    76
    16
    0
    thanks everyone i just got a call from the dealer they said the bolts backed off the rotor and destroyed the alt stator then fried the reg. the service rep told me i can take pics to show all. I am sooo glad i paid extra for the ESP!!!!! or it would be $850 THE moco should really look in to this problem its very common as i read and again thanks GLIDER!!!!