Starters Same or not

Discussion in 'Touring Models' started by joebatterzz, Feb 17, 2011.

  1. joebatterzz

    joebatterzz Member

    9
    13
    1
    Hey Everyone,

    I ride an 08 ultra glide 105th anniv model, and upgraded at purchase to the 110 motor. When I start the bike the starter seems to grind every 4th start, the dealer said the starter does not always mesh correctly and its a known problem, I always shut the bike off turn key back to off then try again and it starts right up. My question is this, do you think the starter which was for a 96 cubic in motor is a different model then what would normally come on the 110 motor if purchased with SE bike. I am considering purchasing a beefier starter, what are your thoughts on the above issue.

    thanks for the insight.
     
  2. gasbag

    gasbag Active Member

    356
    28
    1
    Anytime a dealer says "they always do that" I find another dealer.
    Just my 2 cents which is worth .075 cents adjusted for today's rate.:D
     
  3. Chopper

    Chopper Senior Member

    1,632
    48
    18
    Could be a problem with the teeth on the starter drive or clutch hub, they don't all do that and if they do there's a problem. The stock HD starters are good, does the 110'' heads have compression releases?
     
  4. tkeswede

    tkeswede Member

    76
    18
    1
    I would go with one of the more powerful starters on the market for that big of engine. While your putting that in check all the teeth on all the gears. Might check alignment if that is an issue.
     
  5. Breeze3at

    Breeze3at Well-Known Member

    4,645
    83
    124
    If your stock compensator was not upgraded when you went to 110", I'd suspect that as much as I would the starter. The '07-'08 stock compensators have been discussed at length here and on other forums. A thrashing/grinding sound when starting is a symptom. Some say it's just an internet problem,,, but it keeps coming up.
     
  6. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    #1 on this Chopper, it happened to me:s
     
  7. joebatterzz

    joebatterzz Member

    9
    13
    1
    Yes the 110 has combustion releases. Thanks to all for the insight, I will check with a different dealer, I have the extended warranty, so if it breaks at least I am covered.
     
  8. johnkarlfl

    johnkarlfl Active Member

    168
    0
    0
    I have the stock 96 engine 08 and have never had that happen with the starter.
    Just my .02 cents
     
  9. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    A lot of 07 models had a hardening issue with the ring gear:s
     
  10. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    Go along with Gasbag & Smitty...finding another dealer would be a good thing, as well as properly documenting the problem so the the 110 upgrade is covered...just in case. And as Chop said, probably a good idea to check for damaged teeth and such, cause it is NOT normal and they DO NOT "--all do it..."!:newsmile091: