Starter Problems - 07 Street Bob

Discussion in 'Dyna Models' started by Stuarty, Apr 15, 2009.

  1. Stuarty

    Stuarty New Member

    3
    11
    0
    My buddy has 07 Street Bob and has experienced trouble since 1600 miles. The issues surround the starter circuit. The bike would sometimes start by just switching on the ignition and not pressing the start button. Another issue was the starter trying to engage when the engine was running, sometimes even when the bike was in motion.

    The bike has been in the dealership 6 times. The work done to rectify the problem includes replacement handlebar starter switch, wiring fault, and 2 starter motor relay switches. The most recent change was a replacement starter motor. When the bikes owner was told it was ready for collection he went along only to find the bike wouldnt start. It wouldnt even turn the engine over.

    The shop is now convinced that the starter relay switch is the problem and intend to put in another one.

    Has anyone heard of similar problems?

    TIA:)
     
    Last edited: Apr 15, 2009
  2. glider

    glider Veteran Member

    25,464
    108
    44
    More than likely there's a pinched wire when they did the bars.
     
  3. NYHarley

    NYHarley Active Member

    120
    26
    0
    My 07 Night Train starts when you switch it to run. I was out for a test ride around the block and noticed a noise when I had the clutch in (it was the starter motor running) and pulled over to check. I switched the bike of, and when I switched back to run to start it, the bike just started without even hitting the start button, and the starter motor keeps running. I trailed it home yesterday in a rain storm, is it possible something got wet and is shorting out?

    I just started to have this problem on the 07 Night Train I brought home yesterday. Everything was fine yesterday on my test ride, when I got it home etc... Today I went out for a ride, got a couple miles from my house and could here the starter motor when the clutch was pulled in. Pulled over switched the bike off, and now whn I switch from off to run the bike just starts without even pressing the start button. The bad thing is you can't ride the bike with the starter motor running (unless you want to damage it).
     
    Last edited by a moderator: May 17, 2009
  4. wildspirit97

    wildspirit97 Senior Member

    1,088
    46
    0
    Re: 07 Night Train starts when you switch to run..

    Hard to say but I would start by taking of your switches on the right side to see if you can see anything shorted out. They're pretty easy to remove.
     
  5. glider

    glider Veteran Member

    25,464
    108
    44
    Re: 07 Night Train starts when you switch to run..

    Either wet or something is crossed up in the wiring. Have any changes been made on the bars/switches?
     
  6. H4U30

    H4U30 Member

    68
    16
    0
    This just started happening to me on my 09 Street Glide. I just got back from a ride from Maine to Myrtle Beach and back. The following day I washed it and went to leave for a ride. As I was sitting with it idleing while the gf was getting on the starter engaged by itself. I shut down and once I turn the run switch on it starts by itself. Now its doing it intermitenly.
     
  7. NYHarley

    NYHarley Active Member

    120
    26
    0
    Brought my 07 Night Train to the Dealer cause it was still under factory warranty. They said it was the starter switch, and I haven't had any problems since. Not to mention that it didn't cost me a thing.... I will be sad when the warranty is up.
     
  8. Custom07

    Custom07 New Member

    1
    0
    0
    I got the same problem as you guy's. I have a 07 softail custom. I decided to change the button for the switch for chrome ones. I was taking the start button off when the spring inside the button felt down.

    After putting the spring back in with the new chrome button. I was wondering if my bike would start. So I decided to try it out. I went and turn my key switch on, it the button to run and the bike just start without touching the start button.

    So the bike when on without hitting the start button. And then I did try a few things and find out that if I press on top of the start button, the bike want start by just pressing the run button. But as soon as I use the start button to start it up, I have to press on top of the start button to make sure on the second start the bike want start on the run button cause it will if I don't do it.

    What do I need to do to fix the problem?
     
  9. NYHarley

    NYHarley Active Member

    120
    26
    0
    The switch needs to be replaced. Luckily my bike was still under warranty when I had the issue, and the dealer replaced the switch free of charge. If you replace the start switch you should be ok. You can always start the bike and pull the starter relay out so it won't try to start while it's running, quick fix to get in a ride or two... :)
    [​IMG]
     
  10. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Yep, it ruined my ring gear, H D replaced the entire clutch hub and clutch as long as they were in there