starter noise

Discussion in 'Engine, Fuel and Exhaust' started by wayneb1956, Nov 8, 2011.

  1. wayneb1956

    wayneb1956 New Member

    2
    0
    0
    I have an 08 ultra classic, 53k, when engine is hot and i hit the starter button it sometimes sounds like the engine is coming apart. I have checked flywheel , bendix gear, all looks good. nothing looks worn, only does it when it is hot. any ideas?
     
  2. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    Not sure on what year they changed over but it sounds like your compensator needs an upgrade to the SE.
     
  3. wayneb1956

    wayneb1956 New Member

    2
    0
    0
    Thanks, HDDon. had a new extender shaft put in about a year ago,BUT, i is making the same noise again,I will most def check it out.
     
  4. Iceman24

    Iceman24 Well-Known Member

    3,224
    48
    13
    Agree w/HDDon...sounds like your comp is on the fritz...
     
  5. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Harley Davidson Community This may help
     
  6. Trek

    Trek Junior Member

    575
    26
    1
    I have an 09 ultra and wonder if I am having the same problem. At times when I start it it seems like the starter kicks back or something, that is the only way I can explain it.
     
  7. craig Lee

    craig Lee Active Member

    294
    28
    6
    Have an '08 SG with 58,000 miles and mine started grinding once in while starting around 51,000 miles even with the SE Compensator. It sounded like the starter. Had the original battery, so put in a new one around 55,000 miles and haven't had an issue since. Just an idea.