Starter issues?

Discussion in 'Engine, Fuel and Exhaust' started by LovinTheDeuce, Mar 1, 2014.

  1. LovinTheDeuce

    LovinTheDeuce Member

    11
    0
    0
    Have a question I hope you guys might help with. I have an 07 Softail Deuce. When I start the bike it makes almost a grinding sound but it starts.

    I was getting the rear tire and brakes replaced and when the service department heard it and they were saying that they had heard of a problem with some models and there may be a recall or kit to fix it. I didn't see any active recalls for my bike unfortunately. Does anyone know of an issue like this?
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Some 07 models had ring gear problems, tho they never issued a recall notice Do you have a stock comp sprocket? They have been known to cause premature starter failure ( starter bang) if you will for lack of better wording
     
  3. LovinTheDeuce

    LovinTheDeuce Member

    11
    0
    0
    Everything is stock still.

    Thank you for your help and suggestions.
     
  4. mc2

    mc2 Active Member Contributor

    254
    28
    7
    I had the grinding issue when the engine was started at running temperature, and really rough when hot. A painful sound.

    Always started well when cold.

    I checked and tested all suggestions, but the grind persisted.

    After the ice and snow came, I was told the starter is under-amped. Sounded practical, so I bit into the budget and bought a starter at, 0.2 amp over stock. I think that's a 6.2 or 6.4 amp.

    I'll find out this spring.