Starter engages with run switch

Discussion in 'Sportster Models' started by Sleepnhunter, Aug 4, 2010.

  1. Sleepnhunter

    Sleepnhunter New Member

    2
    0
    0
    On my 2008 1200xl the starter is engaging when the run switch is pushed and not with start button and when running when engaging clutch all the way you her the starter kick in . Pleas help Sturgis this weekend end long ride ahead Thanks
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Have you changed anything on the bars like housings etc?

    It sounds like you have a short possibly caused by the harness in the right side assembly being squashed by the housing. You may need to open the housing up and check the wires inside the housing too.
     
  3. Sleepnhunter

    Sleepnhunter New Member

    2
    0
    0
    wireing looked good , swiched out start switch and seemed to fix it working normal now , will try to get oem switch from diller tomarow THANKS FOR THE HELP
     
  4. Jonas

    Jonas Junior Member

    408
    0
    2
    Sounds like the Start Switch might have been stuck in the closed position. Did the starter try to run when the bike was in neutral?
     
  5. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Man that must have been a terrible noise. I cringe just thinking about a pinion gear engaging with a moving ring gear.
     
  6. rancid

    rancid Active Member

    257
    28
    1
    ive seen this once with a starter and also on a turn signal, which is the same switch. the switchs were faulty and required replacing, very hard to get the switch to fail connected to a meter, disconnect the switch under the tank and put an ohm meter on it to see if it will complete the circuit at some stage. also check for shorts when its all apart.
     
  7. dangerdan

    dangerdan Junior Member

    922
    26
    0
    You might want to check the oil in the primary for metal chunks.