Start up problem

Discussion in 'Softail Models' started by joydol, Sep 18, 2011.

  1. joydol

    joydol New Member

    3
    0
    0
    2007 Softail Deluxe will not turn over. When I install the battery back in everything comes on but when I go to start it, no go. I had my battery tested at 3 places one being Harley Davidson. They say it test fine.
    My bike sits a lot. Could this still be the battery even though it test okay?
     
  2. Dr. Dolittle

    Dr. Dolittle Experienced Member Staff Member Moderator Contributor

    6,399
    108
    24
    If the battery's good it could be the starter, starter switch, or starter fuse that's bad.
     
  3. joydol

    joydol New Member

    3
    0
    0
    Well since its a 2007 with only 5000 miles I will try the fuse first. Thank you
     
  4. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    Check the starter relay also. We just had and thread where the starter relay socket had corrosion.
     
  5. 90FXRS

    90FXRS Junior Member Contributor

    419
    28
    6
    Wondering if when you try to start it does it make any noise? A clicking or anything? Would be nice to be able to get to the solenoid cover. Take it off and physically engage it. The exhaust is in the way I'm sure.
     
  6. dangerdan

    dangerdan Junior Member

    922
    26
    0
    Pull the Solenoid wire off. Connect one side a Dc voltmeter to a good ground and the other side to the Solenoid wire. Start the bike. You should see 12v DC.
     
  7. joydol

    joydol New Member

    3
    0
    0
    Thanks to all of you who responded on my problem. I finally called the HD service department and the rep said you need to change the battery on your alarm fob. Guess what? That was the whole problem. So just thought I'd let all of you good people know. Just in case it ever comes up again. :)
     
    Last edited by a moderator: Sep 20, 2011