stalling problem

Discussion in 'Touring Models' started by hdultra2010, Oct 26, 2014.

  1. hdultra2010

    hdultra2010 Member

    64
    0
    0
    ok guys , i haven't ride my 2010 ultra classic for about month due to weather here . has half thank of gas in it as it shows i still ride another 100 mile before fill up. so this weekend was warm enough to ride , start the bike , idle for few minutes, then head out and fill it up, in first gear while am turning to gas station it was stalling like it want die , fill up gas and went for 40 miles ride , while am riding it was stalling all the way , scared the hell of me ughh.
    take her back to the garage , thought maybe the battery need charged , check the battery and if it charging , it was full and it is charging .
    dont know where to start ? and why it is stalling more at lower speed than high speed 80 mph.

    btw i put her on jack and start her up and start shifting , hitting 50 mph with no problem .
    thanks for the help
     
  2. stray dog

    stray dog Junior Member

    443
    26
    0
    how old is your battery?
    have it load tested.
     
  3. hdultra2010

    hdultra2010 Member

    64
    0
    0
    i dont know how old the battery is , just bought the bike few months ago. i didnt take the battery for load test but just used the voltmeter to check if it is charging
     
  4. stray dog

    stray dog Junior Member

    443
    26
    0
    I'm assuming the bike ran good and the gas was good as of a few months ago.
    I'm also thinking the battery is original from 2010. Seems like everybody gets different life from these batteries.
    A battery can take a charge but that does not mean it is good. Get it charged and have a load test done. That will tell you. Also clean and check both ends of the cables to start with.
     
  5. hdultra2010

    hdultra2010 Member

    64
    0
    0

    yea it was runing good before and it start fine as usual just when riding that it stall. i am going to take the battery off and get it checked and clean the end as u said thank you , hopefully thats the issue ...
     
  6. stray dog

    stray dog Junior Member

    443
    26
    0
    Yea hopefully it something simple.
    Check plugs and wires also. I've found rub spots on wires a few times and it's simple to check.
     
  7. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    Any check engine light???
     
  8. Breeze3at

    Breeze3at Well-Known Member

    4,643
    83
    124
    If the battery will start the bike, it is not the reason the engine stalls at idle. You may have a dirty IAC (Intake Air Controller). They get gummed up and will cause stalliing, especially on a warm engine. There is self help tip on how to clean it.
     
  9. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
  10. Harttoo

    Harttoo Senior Member

    1,104
    68
    80
    Sounds like intake leak if it wants to stall after warm up.