Squeaking noise when hot on sportster

Discussion in 'Engine, Fuel and Exhaust' started by 1cavvet, Sep 29, 2011.

  1. 1cavvet

    1cavvet New Member

    4
    0
    0
    I have picked up a squeaking noise when my engine gets hot. Bike runs great with no loss of power. New exhaust gaskets, fresh oil and filter. It only squeaks at idle when hot and when you raise it off idle it stops.
     
  2. Webbtron

    Webbtron Banned

    583
    0
    1
    In my manual refering to the exhaust there are notations to not let the exhaust touch the frame. other than that I'd look at whatever was worked on last.
     
  3. 1cavvet

    1cavvet New Member

    4
    0
    0
    no exhaust hitting frame anywhere and exhaust shields are tight also
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    Try isolating the area where it's coming from. To say there's a noise will take about 200 guesses where it could be coming from and never find the source.
     
  5. 1cavvet

    1cavvet New Member

    4
    0
    0
    It appears to be coming from front jug around the rocker box
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
    Do you have stock push-rods or adjustable push rods in the engine?
     
  7. 1cavvet

    1cavvet New Member

    4
    0
    0
    as far as i know I have stock push rods
     
  8. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    Since you are having trouble isolating the sound, they have dignostic stethescope and like Steve says, spray grease (I use good ol' WD40) and spray around the exhaust system joint and manifold locations. Remember, since you do not have rubber mounting, you may want to check for loose hardware. On my '04 (it HAS rubber motor mounts and links, but I still have seen vibrations loosen mounting hardware, even the baffles inside my pipes, with just a 1/4 turn of tightning. Also the chain tension is manually adjusted, so you may need to view a service manual to help map your strategy.