Squeaking clutch

Discussion in 'Transmission' started by adams777, May 19, 2010.

  1. adams777

    adams777 Member

    Hi there

    Custom built with Evo engine from 1996

    Pretty new clutch – some 300 mils....has funny squeaky noise like a belt in the car...the noise is present only when I start when releasing the clutch lever from neutral to 1st gear...after that the changing gears is okay and no noise....

    The clutch adjustment has been done, actually this new clutch was placed as I the old was giving me the same funny noise and was a bit sliding....but this one is pretty much brand new and Heavy Duty so not sure why I still hear that squeaky noise – may not be the clutch?????.....the primary chain is pretty much okay, although I am not sure how to measure 7/8 of a play – do you measure it from the neutral position and rising it up? Or is it from the up position to the down position of the chain in the middle? I measure it the second way by the way – but not sure if this is correct?

    My guess with regards to the squeaking noise would be the bearing inside the clutch basket....why? well, I am not sure if my chain is inline – as I had a offset 1,5 inch and when installing the chain drive I believe I did not put the compensation washer at the front – and since I misplaces it I am not sure how thick it was – any idea how to measure it? I have a number of different once co I could play with it and hopefully finally find the inline position, but how to adjust it? How to find the right thickness of the compensation washer? When I look at the chain with my eye it looks okay but...:)??????

    So my theory on it that the chain is not inline and the bearing has been damaged and that’s why it gives that funny noise in the clutch are...Please let me know your thoughts.