Sputtering

Discussion in 'Engine, Fuel and Exhaust' started by Redman1, Jun 6, 2016.

  1. Redman1

    Redman1 New Member

    4
    1
    0
    I have a 2012 Road Glide Ultra I have changed oil-stator-regulator-air filter bike was running fine for about 4 hours now bike is sputtering and light is coming on can somebody tell me what you think problem is
     
  2. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    Have you checked for codes? Which light is coming on?
     
  3. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,593
    103
    296
    As Don said check for codes, codes may tell you what the problem may be.

    Take a look here in the self help section.

    2004- 2015 Harley Trouble codes in depth reading
     
  4. Redman1

    Redman1 New Member

    4
    1
    0
    Codes p0113-p0374-0502-0505
    Check engine light off and on
     
  5. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,593
    103
    296
    If you haven't read your codes check here.
    2004- 2015 Harley Trouble codes in depth reading
     
  6. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
  7. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
  8. Redman1

    Redman1 New Member

    4
    1
    0
    Yes I did that stator is good regulator is good I'm asking what else you think problem could be

    The codes are vss sensors high voltage - temperature controlled sensor
     
    Last edited by a moderator: Jun 9, 2016
  9. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Check the head sensor in the front head behind your horn
     
  10. Redman1

    Redman1 New Member

    4
    1
    0
    Thank really appreciate that