sputtering

Discussion in 'Electrical' started by muttman, Dec 10, 2011.

  1. muttman

    muttman New Member

    1
    0
    0
    97 Roadking 67,000 miles, starting hard backfire thru carb cold or hot also loss of power. I think its my ignition coil but not sure, also not sure how to check coil help:newsmile058:
     
  2. Dr. Dolittle

    Dr. Dolittle Experienced Member Staff Member Moderator Contributor

    6,399
    108
    24
    Would this help?

    Harley Davidson Community
     
  3. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Welcome to the Forum, Harley Davidson Community Have a look here and other pointers in the self help section. The C V carb is cold blooded and lean from the factory, Doe pulling the Enricher out help? If it does you may want to rejet:s
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    How long have you owned this bike and what has been done to it other than stock?

    Has it always done this if you have owned it a while?
     
  5. SledDog

    SledDog Senior Member Staff Member Moderator

    1,852
    58
    42
    Some 96 and 97 model year bikes had problems with the hall effect sensor under the cam cover that tells the module when to fire the coil. One of the symptoms is a back fire thru the carb.

    My 96 dyna had one that would go static at the weirdest times, hot, cold. while riding, while idling, it made no sense. I managed to troubleshoot it when it happened one day. This was after the HD dealer had 2 under warranty "Could Not Duplicate Malfunction" services. With no problem found, I had to pay the shop time.

    I took it to the dealer and they change the sensor. Problem fixed.
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
  7. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    If it just started this and pulling the enricher helps you may have a leak in the intake side. The rubber coller that seals the carb throat to the intake manifold may need to be replaced. Or the carb itself is loose.