Sporty Electrical problem

Discussion in 'Sportster Models' started by theosmithers, Apr 20, 2010.

  1. theosmithers

    theosmithers Member

    14
    0
    0
    My wife owns a 2006 Sporty 1200c. The other day, we were riding, and all of her lights and speedo went dead. When we got home, I checked her fuses. 2 of them were blown. I replaced the one for the headlight, running light and tailight and I'm fine there. I tried to replace the one for all of the other electronics ( brake light, speedo, odometer, turn signals, etc.) and it keeps blowing out immediately (shorted). I've checked as much wiring as I can find, removing the tank to look around there also and I can't find any burn or pinched wires. I've read some of the forums on this site and it says that there are chronic problems in the fuse block. Could this be the problem? Also, how do you remove the fuse block to clean all corrosion?
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
  3. glider

    glider Veteran Member

    25,464
    108
    44
    :lolrolling....Getting better :D
     
  4. theosmithers

    theosmithers Member

    14
    0
    0
    There's one thing that I forgot to mention that I think is strange. When the key is first turned on, normally the bike would make a small buzz (the fuel pump I think) and kind of a quick diagnostic check. Well, during this time, the left turn signal will blink 5 times and then shut itself off. I can't get the turn signals to work any other time. I don't know if this is a clue as to where the problem is or not.
     
  5. glider

    glider Veteran Member

    25,464
    108
    44
  6. theosmithers

    theosmithers Member

    14
    0
    0
    I got it. I lowered the bike, and I guess that I lowered it too far because the tire rubbed on the wiring in the rear fender. I had to take the whole rear end apart and repair all of the wires. But its runnin like a champ, and I raised the bike up a couple of inches so that I don't have to deal with that again.