Sportster Ignition Issues

Discussion in 'Sportster Models' started by kETTLER, May 11, 2009.

  1. kETTLER

    kETTLER Member

    12
    11
    0
    I have an 04 883c that isn't firing from one cylinder intermitently. And fires all the time @ high rpms. Ive changed plugs and wires, and checked carb. finally gave up and sent it to a shop. they have had it for 4 weeks now and do not know whats wrong. they think it may be the ecm. Any info on what else i could check seeing that i brought my bike to a shop that doesn't know anything about motorcycles. And does any one know were i can get an aftermarket ecm.
     
  2. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    Just a little more diagnostics, if you believe the iginition is okay (other than intermittant ECM) did you try using the opposite tactic by finding out what it working or improves function? Try to check the other things i.e. perform compression test...(bad cylinder has to build sufficient compression). Does pulling out the enrichener helps or initiates the miss/cutout. Also did you swap the ignition coil, or the wires to see if it made any difference? BTW is it the front or rear cylinder cutting out?
     
  3. kETTLER

    kETTLER Member

    12
    11
    0
    i Have switched my wires around. and the shop i took it too "said" the coil is fine. and it is the front cylinder cutting out. im picking up the bike tomorrow from the shop hopefully in one peice and will be able to start my own diagnostics on it. thanks for the tips.
     
  4. kETTLER

    kETTLER Member

    12
    11
    0
    Ordered new aftermarket ignition module, will see if that fixes my problems.