speedometer reads 15mph off

Discussion in 'Sportster Models' started by drasher, Sep 9, 2009.

  1. drasher

    drasher New Member

    3
    1
    0
    i have a 2000 sportster hugger 883 and the speedometer reads 15mph even when the bike is turned off and not moving. when the bike is moving its 15 over what it is doing. what can i do to fix this? i tried taking out and cleaning the speed sensor but it looked fine.
     
  2. Bud White

    Bud White Well-Known Member Retired Moderators

    3,270
    48
    2
    gonna have to have the speedo fixed or replace it
     
  3. glider

    glider Veteran Member

    25,464
    108
    44
    That sounds as if it could be the speedo itself if it is over with the ignition off.
     
  4. drasher

    drasher New Member

    3
    1
    0
    can the speedo be fixed and if so can i do it my self?
     
  5. Bud White

    Bud White Well-Known Member Retired Moderators

    3,270
    48
    2
    it shoudl be able to be fixed but cost might be to high chances of fixing it yourself about 0
     
  6. drasher

    drasher New Member

    3
    1
    0
    thanx for the input i'll call about getting it fixed tomorrow, i hate to just get another one because of losing the original odemeter reading, can a new speedometer be set to show the miles i have now instead of starting at 0.
     
  7. R. Lewis

    R. Lewis Senior Member Retired Moderators

    2,183
    48
    5
    instead of the speedometer unit itself being bad - would it be a cable problem ?? Just asking - don't know!!!???
     
  8. ron1978

    ron1978 Active Member

    390
    26
    1
    i also have a 2000 model, mine i think is electronic controled, when i cut key on, my needle moves alittle, and i hear it make faint noise when key first is turned on, so its all elecltric i think, surely it can be recalibrated at dealership , that way you can save data on it