Speedometer issues when wet

Discussion in 'Dyna Models' started by gskidd, Nov 4, 2007.

  1. gskidd

    gskidd New Member

    4
    11
    0
    I recently took my 07 dyna to the beach. I would rinse it in the morning to get the salt air off and found that the speedometer would stop working until it had been ridden for about an hour. It would also idle off when coming to a stop. Eventually it would clear up but it continues to do this when it gets wet. Any ideas.
     
  2. glider

    glider Veteran Member

    25,464
    108
    43
    Some of the sensors or plugs on them could have been infiltrated by water.

    Here's the best thing you can do to dry it up after a wash. Actually blows hot air after it runs a minute or two. The hot air dries things up better than compressed air or leaf blowers do. I have the 4 HP unit and it works very well, cuts your dry time to nothing at all.

    http://www.hdtalking.com/general_tips/1008-motorcycle_blow_dryer.html
     
    Last edited: Nov 4, 2007
  3. gskidd

    gskidd New Member

    4
    11
    0
    Hi Glider, I lost the link to this web site and have just rediscovered it. Thanks for the suggestion but now I find that any water, standing in the road, a brief shower or any contact with minimal amount of water will shut down my speedometer, six gear light, and I will shut down if I throttle down. I take it in for 15k check up Friday, do you have any other suggestions. It kind of difficult to blow dry her out on the road.
    Thanks
     
  4. glider

    glider Veteran Member

    25,464
    108
    43
    Sounds like a connector. Describe the outages in detail to the dealer when you take it in. They should be able to pinpoint the location based on what goes out and find the offending connector.