Speedometer and Odometer not working

Discussion in 'Softail Models' started by MarconBiker, Feb 5, 2009.

  1. MarconBiker

    MarconBiker Member

    8
    11
    0
    Hey guys,

    I need some help with this, I have a Heritage Classic 92 and yesterday night from nothing the speedometer and odometer just stopped, it was working properly.... Do you guys have any idea where to start looking!? The cables in the front rear looks fine...

    Tks in advance,

    MBiker
     
  2. glider

    glider Veteran Member

    25,464
    108
    43
  3. MarconBiker

    MarconBiker Member

    8
    11
    0
    Tks Glider, I saw this before but I wasn`t so sure if it was for the old models, I'll check this out as soon as I leave the office.

    Tks buddy, see ya.

    MBiker
     
  4. glider

    glider Veteran Member

    25,464
    108
    43
    Not sure on the 93 but I don't think you have a cable drive speedo on that bike.
     
  5. hntwrobin

    hntwrobin Active Member

    236
    26
    0
    Speedo cable is probably broken! I had a 93 FLSTC there is a cable.:s
     
  6. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,604
    68
    77
  7. MarconBiker

    MarconBiker Member

    8
    11
    0
    Hello there,

    TQ, I think you're right, yesterday I couldn`t take a deep look at it(I couldn`t take the instrument panel, the chrome, off :unsure), another thing that I realized yesterday is that the automatic turn light stopped turning off with the handlebar... I got a lot of storms this week, not sure if this could be related.
    Anyway, it's look like I have a lot of fun for this weekend.

    Tks, Ride Safe.
     
  8. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,604
    68
    77
    If your speedometer (and odometer) is not working, your turn signals are not going to autocancel. No indication to the module that you have gone anywhere. Find and fix the speedo problem (cable or drive unit) and your turns will work fine.

    TQ
     
  9. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,203
    133
    138
    the speedo inner cable does snap normally about 1" from the drive unit indicators wont self cancell cos it cant count the distance once the cable is snapped
    think 95 was the first year of electronic sensors but they cost a lot more than a cable
    wife has snapped cable on all her bikes not had one snapped on me so far new cable about £10
    is possible to pull the inner and replace it if you have matching set

    Brian
     
  10. Rhyno

    Rhyno Member

    33
    16
    0
    Same thing happened to my 93 Heritage. I had to replace the speedo/odometer unit.