Speedo Problems

Discussion in 'Dyna Models' started by Vince, Mar 10, 2009.

  1. Vince

    Vince Member

    13
    11
    0
    I have a 2009 Dyna Super Glide and when I ride in the afternoon right as the sun goes down it gets hard to read the speedo It has the white background. Anyone else have this problem or any ideas how to fix it thanks for the help Vince
     
  2. ugocon

    ugocon Active Member

    222
    26
    0
    I also noticed that the reading of the 2009 instrument is poor in some light conditions.
    Despite the nice look of the new background, efficiency is lower!:(

    But I won't waste my money changing it: I'll cope with it.

    Ciao
    Ugo
     
  3. DadzLowrider

    DadzLowrider Active Member

    137
    26
    0
    If you look on eBay you will find some companies that make replacement backgrounds that are custom painted, that should fix it. You might also want to try some sort of an aftermarket light tint and put it over it??? Just a thought
     
  4. steve299

    steve299 Active Member

    157
    26
    0
    I have a moisture problem occasionally on my 08 sportster. Any one else see that.
     
  5. glider

    glider Veteran Member

    25,464
    108
    44
    The moisture in the speedo and other instruments is very common. Park it in the sun for a while and it should help.
     
  6. DadzLowrider

    DadzLowrider Active Member

    137
    26
    0
    Yes, I have it on my 08 Dyna as well. I think it is a pretty common problem.
     
  7. steve299

    steve299 Active Member

    157
    26
    0
    Thanks, I was worried I had a bad seal. It isn't clouded yet, but wasn't sure if mine was only one.