Speedo died at 61,000

Discussion in 'General Harley Davidson Topic' started by bigalturk1, Jul 12, 2015.

  1. bigalturk1

    bigalturk1 Member

    8
    0
    0
    Yesterday my speedometer died on my 2000 Softail.
    The mileage digits show but there is no movement.
    Before I buy a new speedo I'm going to troubleshoot it, anyone have a fix?
     
  2. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,317
    73
    130
    Pull the speed sensor and make sure its clean. Sometimes they get metal shavings stuck to it and cleaning it will work.
     
  3. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,317
    73
    130
  4. bigalturk1

    bigalturk1 Member

    8
    0
    0
    Wouldn't that be nice but Nah, I checked that out after I returned home last night.
    Tomorrow I'll look at my repair manual & see if if there's a spec reading (Ohm or Voltage).
    I'm riding out to Sturgis in a couple of weeks so a functioning speedometer would be nice because I recently got a speeding ticket for going to slow "NOT" and I don't need another one!
    Your in Central Florida too? (I'm in Ormond Beach).
    Anyway, thanks
     
  5. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
  6. bigalturk1

    bigalturk1 Member

    8
    0
    0
    Yep, drive it like you borrowed it without permission!
     
  7. bigalturk1

    bigalturk1 Member

    8
    0
    0
    I'm all set now,
    I went to Harley & purchased a speedometer sensor, works great other than the $62.00 VISA bill that I'll be getting next month.
    No complaints though, it's still cheaper than a new speedometer!
     
  8. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,317
    73
    130
    Or a speeding ticket! Good work.