Spark when i turn ignition of or press kill switch??

Discussion in 'Sportster Models' started by krossroads, May 3, 2011.

  1. krossroads

    krossroads New Member

    1
    0
    0
    i have the spark plug out and every time i press the kill switch or turn the ignition off, the plug sparks. i bypassed the kill switch and it still did it. i bypassed the ignition and it still did it. anyone have any idea what this could be????
     
  2. geezer

    geezer Senior Member Contributor

    1,623
    68
    52
    Welcome aboard from Canada. If you post in the Sporster thread you'll get your answers because not everyone reads the new member section.
     
  3. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Welcome to The Forum, do you have the plugs grounded when this happens? I would look at the run switch for a short and possible shorted ignition switch. Do you have power at the coil at all times?
     
  4. Joyflyin

    Joyflyin Experienced Member Staff Member Moderator

    5,324
    118
    93
    Welcome aboard, glad to have you here. :ws
     
  5. mat 60

    mat 60 Senior Member

    1,237
    48
    5
    Welcome from Maine
     
  6. Hoople

    Hoople Account Removed

    7,198
    0
    34
    But other than what you have observed with the spark, the bike runs fine with no problems or issues. The battery is not going dead or your not blowing fuses correct? Your just wondering why the spark jumps the gap when you hit the kill switch.