silence is not always golden

Discussion in 'Communications And Radio' started by Thomas, May 3, 2008.

  1. Thomas

    Thomas Member

    5
    11
    0
    I have an '06 streetglide whose audio system went suddenly mute 2 days after the warranty expired. I did not hit the RR tracks at 110 mph nor have I pressure washed. I heard a rumor about re-programming, any truth to this? If so, can I do it myself? Thanks, Tuneless in Ohio.
     
  2. glider

    glider Veteran Member

    25,464
    108
    43
    Sounds serious with no tunes. Have you checked the obvious like fuses and wiring plus grounds for the radio yet? They are programmable with downloads.

    Welcome to the forum.
     
  3. Fisher

    Fisher Account Removed

    341
    0
    1
    If you have your bike serviced at a dealer approach the service writer and ask if they can help you out.Chances are they will try.They'll try a software update first and go from there if that doesn't work.Are you comfortable with software?If you are I can guide you through a reset procedure.Just say so and I'll bring the book home Tuesday.
     
  4. Thomas

    Thomas Member

    5
    11
    0
    Thanks Glider, Yes, I checked for all the usual suspects (wires, fuses, etc.). Nothing obvious. My wife downloaded the upgrade program and successfully installed it but still no sound. However, a note appeared which read "FL SPKR OPEN". I smell a dealership moment. Tom aka zippy
     
  5. Thomas

    Thomas Member

    5
    11
    0
    Thanks Fisher, even after a successful download, all that appeared was a note saying "FL SPKR OPEN". This one may be beyond my scope. All my previous wiring experience has been with the 32 and 52 E 6V 3 brush systems. The dealer has waived the expired warranty issue and offered to repair it for free. I must live right. Thanks again. Tom aka Zippy
     
  6. glider

    glider Veteran Member

    25,464
    108
    43
    Interesting....check the speaker output wires?
     
  7. Thomas

    Thomas Member

    5
    11
    0
    They seem to be intact. I'm thinking he circuit may be open from somewhere deep within the bowels of the receiver. When we get it back from HD I promise I'll post the diagnosis. Thanks again for all the support. "Advanced Audio Systems!" Remember radios? Zippy
     
  8. HarleyHarry

    HarleyHarry Banned

    548
    0
    0
    Yeh, there's somthing to be said for simplicity!
     
  9. Fisher

    Fisher Account Removed

    341
    0
    1
    Yeah I hate the computerized radios.I use an iPod.
     
  10. Thomas

    Thomas Member

    5
    11
    0
    Quick update, the "Advenced Audio System" had an open internal circuit. Upon removing the fairing the dealer noticed a broken bracket on the lower left side causing severe vibration at idle speed. He said that this was not uncommon. The vibration caused the lower left fairing screw to vibrate out. This also happened to a friend with an ultra classic. Perhaps rubber motor mounts and high tech electronics are a bad combination. This may be worth checking periodically. Anyway, thanks for the support and be careful out there. Zippy
    How come you never hear about Mack the Fork?