Short Battery Life for Harley's?

Discussion in 'Touring Models' started by bobalu, May 10, 2013.

  1. bobalu

    bobalu Active Member Contributor

    129
    26
    0
    I have a 2010 Road King Classic purchased new in 2011 (left over model on the sales floor).

    Bone stock and runs like a Swiss watch. I've stored it at the dealer over the past 2 winters with a Battery Tender on it, and its plugged into the Battery Tender at home when I'm not riding.

    Went out to ride on Sunday and it would start. Just a clicking sound, like when a starter goes bad on a car. Full lights, instrument lights, horn all worked fine with no dimming. It just kept "clicking" when I hit the start.

    Dealer trouble shooted it and said the battery was done. Cold Cranking amps were way down (tested under load).

    Anyway, after my long story here, all I'd like to know is did I just have a bad battery from the factory or is 2 years a normal life span for an HD battery? This is my first Harley, and I've only ever had imports with my battery's all lasting 4-5 years with no problems. If it matters, I was using the small Battery Tender Jr. trickle charger. The old battery seemed to be charging fine. After a ride I'd plug it in, red light on the charger for about 2-3 minutes, then it went to flashing green.

    Only 2 years for a battery is pretty bogus if you ask me!
     
  2. STEVE07

    STEVE07 Well-Known Member Staff Member Super Moderators

    4,011
    68
    30
    My 07 had it's original battery until last march when it gave up.
     
  3. HDSickness

    HDSickness Banned

    418
    0
    2
    Seems to me your battery was at least 3 years old and if it sat in the showroom for 1 year not on a tender that could have helped with it's early demise.
    You should get at least 4 years out of a new battery.
    I do not think there is anything too unusual about your situation.
    Harley brand batteries are good quality.
     
  4. Taildraggerdave

    Taildraggerdave Active Member

    164
    28
    2
    My '05 battery died in 2012 and my '09 battery is still going.

    I'll probably get arguments for this but I don't believe in leaving a battery
    on a tender for months at a time.

    I'll hook a tender to the battery once a month if the security system is active and once every 3 or 4 months if it is left off.

    I agree that your battery should have lasted longer.

    Take care,
    Dave
     
  5. SixPak

    SixPak Junior Member

    407
    28
    3
    My bike is an 07 and it still has the original battery.
     
  6. bobalu

    bobalu Active Member Contributor

    129
    26
    0
    I wasn't counting the year it sat on the showroom floor as it would be no different than the battery being on the stockroom shelf. I guess it counts though given that the batteries are fully charged and sealed when delivered. So what happens if you buy a new battery that's been in the stockroom for a year or two? I'm old school and remember when you had to add electrolyte to the old lead acid battery's when you bought them! (they were shipped dry).

    Thanks for the responses guy's. :hii
     
  7. BUBBIE

    BUBBIE Well-Known Member Contributor

    4,921
    58
    78
    My 1997 EVO was sold at 3 years old(4th year com'n out) so I felt a discount on that Battery and a Friend buying that bike was in order.. so 50$$ off..

    3 years later I asked him, ? what kind of battery did you end up putting in the Bike? Me saying: You know that was an experimental Gel type Battery in there from new don't you?...

    He tried to stay away from the question..... I asked again?

    He said it was the SAME Battery I sold to him in the bike...

    No he never gave back the 50$$...

    I looked for that gel battery from HD but never found it.... Probably it Lasted TOO Long.

    I have the Original battery in my 09 King... I bought the bike when the end of the 09 model year was there and the 2010's Just came out... August of 09

    5 almost 6 Model years? That really surprises me. DANGER BUBBIE !!!!!

    Today while parked over by Fort Huachuca, Rays for breakfast.
    Parking my bike with the group, in front, Plain View,. KNOWING I Shut off my Ignition Knob and leaving in gear,seeing red oil light then turning off the switch knob... Locking the bars like I normally do.

    Coming out to find my Knob Switch turned ON....The group was saying Old Age :yeahright

    I turned it off for a few minutes to Rest. By the time we were rolled out for the start. I turned on (good for a brief rest as the juice comes back a little)

    Hit the button and woo-woo then started Luckily it hit, WEAK turn over but fired off. (high compression with the SE 255's)

    Battery is Kept Up only from normal riding (almost a ride 3 time at least a week and always long ones). Never had a trickle charger on it.
    Had it checked out a while back at HD shop ?? Machine that printed a read-out... saying A Okay... Showing all the things Hoople would understand:bigsmiley28:

    Now my 06 Sport R 1200 sits a Long time and I do use a trickle charger continual on it. 3 year old battery now. Kicks over like a champ.

    signed....BUBBIE
     
  8. oldhippie

    oldhippie Senior Member

    1,049
    58
    13
    Bad battery is my guess. I'm on my 5th season with mine OE battery. This past winter is the first time I'd left the tender on all winter. Prior winters I'd just put it on for a day each week except when we were extremely cold (-30C or lower) then I'd leave it plugged in until it warmed up over -20C.
     
  9. r_k_dragon

    r_k_dragon Active Member

    270
    0
    4
    2011 Ultra Classic and had the warranty, like one month before the two year OE warranty expired, cover the battery replacement. Go figure!
    Work ride, all year long yes, and never tendered!

    And BUBBIE, I never leave my switch on!

    Steve
     
  10. turnup

    turnup Member

    40
    16
    0
    Just replaced original battery on my "04 sporty. When pulled iit out saw an '03 date stamped on it. It never did quit orleave me stranded but Was starting a bit sloww on real cold mornings. Figured best replace it before it did.