screamin eagle oil slobber

Discussion in 'Other Service and Maintenance' started by oleslookin, May 2, 2011.

  1. oleslookin

    oleslookin New Member

    3
    0
    0
    My 05 ulta engine is now 113, tuned exhust, did it at a hd dealer it runs great, starts perfectly, got better on gas use, however
    oil pressure is at 40 lbs all the time, oil temp is 240 with outside temp at 42. and upon decelerating oil boils out of the aircleaner, the hotter the outside air temp the worse it gets. added an oil cooler, made the diffence of 40 deg it used to be 310 deg. it will do this till all the crackcase oil is gone. (synthectic oil hd used)
    so is it, oil over relief, to high pressure, what?
    I have over 6000 miles on this engine is been doing it since day one.
    totally frustrated and ruined lots of clothes and rear brakes.Ideas!!!! I will listen...
    but it has to come to an end or .........
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    You should consider a better oil for the engine but it sounds like you have an oil ring control problem. Let the dealer figure it out and possibly replace the oil rings on the pistons to stop it.
     
  3. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    This is one I was at a total loss with. What are you thinking, back pressure blowby?
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    My school of thought is that being it was happening since day 1, the oil rings may be defective/broken or installed wrong causing the oil to be pumped UP instead of pulled down.
     
  5. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,279
    133
    158
    I had this on an engine in the past if there is badly fitted or worn rings the pressure from the burning fuel can get passed the piston and pressurise the crankcase forcing the oil that is in the crankcase out of the breather the faster the engine goes the quicker the oil comes out

    Brian
     
  6. Breeze3at

    Breeze3at Well-Known Member

    4,645
    83
    124
  7. oleslookin

    oleslookin New Member

    3
    0
    0
    i will check this out but. I find several others with the same issue but they are 103.
    i have great compresion. in fact the dealer told me I am at 13 to one?
    you maybe right however, I did use amsoil and it still occured
     
  8. glider

    glider Veteran Member

    25,464
    108
    44
    13 to 1? WOW, you must eat up starters for breakfast.
     
  9. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    While I agree there are better oil products that can be used, I don't think changing oil will do anything for your problem. Something is causing the oil to be forced up to the rocker box area. Has the dealer offered any ideas on the cause? The others that are haveing this problem, did they also have the work done by the same dealer?

    Did the dealer tell you what the compression readings were? Compression Ratio is derived by what the squish band area is, and if you indeed have 13to1 CR you would probably have to use an octain booster or some type of gas with an octain rating higher than pump gas.
     
    Last edited by a moderator: May 2, 2011
  10. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    When BLOW BY gets around the rings it HEATS up the inners, IT will BOIL any OIL inside the bottom-top end like you are doing.... Such a HIGH Pressure in a cylinder head is hard to Hold , even with good Seated Rings...

    You must have Blow By and from the start... What does the Builder say???

    WHY 13/1??? Man that is only for the strip and are you riding it on the road???:newsmile07:

    I would go there First (builder) to see if they will do a leak-down test. OR what do or did they say about the problem...???

    signed....BUBBIE