runs rough off idle

Discussion in 'Sportster Models' started by orgredneck, Sep 3, 2010.

  1. orgredneck

    orgredneck Member

    61
    16
    0
    runs rough at low rpms
    checked codes
    got a po261 and po263
    need help
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Use the search box and self help section
     
  3. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Would be great to know a little about the bike. What have you done so far?, mileage on bike?, factory stock? stage 1?, piggy back tuner?, factory download? how quickly do codes reappear after clearing them?
    additives to fuel?

    Wish it was that easy but without any info. you know know more about it than we do.
     
  4. orgredneck

    orgredneck Member

    61
    16
    0
    2009 sportster 1200L
    8009 miles
    screaming eagle slash out mufflers,
    screaming eagle air cleaner,
    harley download all done at 1000 mile check up,
    runs rough at low rpms surges hot not as bad cold
    just started,
    did not clear codes just found them,
    front and rear injector open/low efi
    no check engine light on
     
  5. Hoople

    Hoople Account Removed

    7,198
    0
    34
    It is strange both of those codes are appearing together. Since the bike is running poorly, I would clear the codes and see what code appears 1st and how fast. As soon as you see the engine check light appear, check to see what code logs.
     
  6. orgredneck

    orgredneck Member

    61
    16
    0
    today cleared codes,
    ran good,
    rode 35 miles,
    no check engine light on,
    stopped checked codes ,
    p0261 and p0263 back ,
    checked fuses and both relays
    looked clean with grease on them,
    looked at inj. wires can't find break,
    rode 35 miles home no codes.
    anybody have any ideas.
    thanks,
    orgredneck
     
  7. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Was work done by dealer, should still be under warranty
     
  8. orgredneck

    orgredneck Member

    61
    16
    0
    no work done by dealer,
    can't get in for 2 weeks,
    never get check engine light on,
    cleared codes last night,
    checked codes this morning there back,
    did not start bike ,
    can codes be set Without running bike,
    has me confused
     
  9. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    The DTC codes indicate the following...

    P0261 Front Injector Open/Low EFI
    P0263 Rear Injector Open/Low EFI

    So my first question, notice anything odd at startup or running regarding fueling...maybe check the wiring routing up to the injectors for pinched wires and inspect connector contacts for symmetry and such.

    It could be loose connection, or intermittant problem, but as others have stated, it is under warranty and worthy of having the repair/trouble ticket reflect this in case there is future issues by taking it to the dealer ASAP.
     
  10. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Have 1 Very important question. From the time the codes are cleared to when they reappear, does the bike "kick" or appear to have an ignition miss even for a fraction of a second. Does the bike experience what I would call an "ignition miss" as if the ignition key was turned off & back On for a fraction of a second.. Do you experience anything like that.

    There is a vital electrical connector on the Sportster that I want you to check. It is a 14 pin connector that is between the ECM and the Injectors. It is called connector #145.
    Look especially close at pin #7 (yellow/Green wire) of connector #145. Unplug the connector and make sure pin #7 is clean and tight. Don't spray anything like WD40 into it. Use the correct contact flush (Deoxit5), and reassembly. Unplug, clean, inspect, flush & lube connector #145.

    If pin #7 was not making good contact, you would post Both codes at the same time very quickly, and the bike would run WITHOUT the engine miss above. If you do experience an engine miss (even only if 1 time) post that info.

    After you check and clean #145, clear the codes, ride bike and see if codes come back. Pay attention for signs of engine miss.

    Post what you find.