Running with Rich Mixture

Discussion in 'Sportster Models' started by mvhgraphics, Jan 13, 2009.

  1. mvhgraphics

    mvhgraphics Member

    5
    11
    0
    My 07 1200N EFI is running SE Slip ons, stock ham can and air filter with a Boyesen Power X Wing. These mods were made by previous owner. Bike has had 1,000 mi. service by dealer). When I roll and snap the throttle I get a (Small) flame shoot from the exhaust. I understand this is unburt fuel in the exhaust. This is a mixture problem (Running Rich) Should I schedule my 5,000 mi service early or can this wait till I reach that point? I only have 2500 mi on her now. The bike doesn't pop when you let off the gas and runs well at all stages of acceleration. My question is am I doing any damage to engine? I don't make a habit of doing this (rolling the throttle) but was concerned.

    Thanks,

    Michael Hinojosa
    Dutchtown, LA
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    What you are seeing could be the result of the extra fuel added when twisting the grip and not necessarily a problem.

    Not sure if you are FI or carb, more than likely FI but it would be nice to mention it.

    You also mention an 07 but your avatar says 08
     
  3. kemo

    kemo R.I.P

    1,690
    48
    5
    You could be running rich enough to wash valuable lubricating oil off your cylinder walls and contaminating your crankcase with fuel. I would get it looked after ASAP
     
  4. mvhgraphics

    mvhgraphics Member

    5
    11
    0
    07 1200n efi

    Thanks!
     
  5. glider

    glider Veteran Member

    25,464
    108
    44
    Have the dealer check possibly if a stage 1 download was installed being you are running the stock ham can. It could be the reason for a rich mixture.
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
    Agreed, somebody spent $130 and could have gotten something worthwhile instead.
     
  7. mvhgraphics

    mvhgraphics Member

    5
    11
    0
    No stage one or extra fueler. My question is am I doing any damage to engine? Can I wait till my next service at 5,000 miles. I guess I should check plugs first Huh? That would tell the truth. Is the xWing causing any of this?
     
  8. glider

    glider Veteran Member

    25,464
    108
    44
    Hard to tell from here if you even HAVE a problem. How do you know if there is a stage one download in the ECM?
    The X wing sure isn't helping you any . They claim 4 HP and 5 TQ which I find hard to believe myself with just that device. It's like the old screens that mounted in the carb to atomize the fuel better :D