running not quite right

Discussion in 'Softail Models' started by 1tinner, Aug 30, 2009.

  1. 1tinner

    1tinner Member

    5
    1
    0
    I have a 98 fxsts. just had a crane fireball cam installed this spring. Also has arlen ness air filter....python3 exhaust...still has stock cv carb with only minor work done to it...still has original stock ignition module...also bike has 27000 miles...now to the problem....bike has intermittent hesitations and popping out of exh. at higher rpm;s...slower produces some jerking and hesitations...just had new intake seals installed and when these were done the carb was taken off and cleaned..for 2 days it ran like a top..then back to problems listed above..would appreciate any ideas and opinions..if anyone needs any additonal info please let me know...thanks
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
  3. 1tinner

    1tinner Member

    5
    1
    0
    thanks for reply Glider....actually the bike has been dyno tested and appropriate jets supposedly installed..im still wondering about that....i did install an inline fuel filter right after petcock and have been thinking about taking it back off..dont think i had problems before i put that on...could it be?
     
  4. vtbikers

    vtbikers Active Member

    174
    26
    0
    I think Gliders right. I would check the filter on the petcock. Does it get worse on reserve?
     
  5. 1tinner

    1tinner Member

    5
    1
    0
    i have had to turn it to reserve once with the problem....and yes i do believe it did get worse..now that i think of it the lower the tank gets the worse i believe it does get
     
  6. vtbikers

    vtbikers Active Member

    174
    26
    0
    Sound like you have a bunch of trash in the tank and the screen in the tank is cloged
     
  7. 1tinner

    1tinner Member

    5
    1
    0
    i will surely give that a look....thanks for ideas
     
  8. 1tinner

    1tinner Member

    5
    1
    0
    took screen out of tank and cleaned.... replaced it and same symptoms...anybody with any other ideas?
     
  9. glider

    glider Veteran Member

    25,464
    108
    44
    Remove the inline filter you installed. Could be enough to slow the fuel delivery. Remember the fuel is gravity flow, no pump and a slow moving fuel filter could be the problem with fuel supply.
     
  10. vtbikers

    vtbikers Active Member

    174
    26
    0
    What do the spark plugs look like? You should rejet the carb. And maybe check the ignition timing if it has not been done.