Running lights

Discussion in 'Electrical' started by 07Classic, Sep 30, 2010.

  1. 07Classic

    07Classic New Member

    The fonts running lights on my 2007 FLSTC are not working but the flashers are!!! I checked the fuses and all seem fine. Any suggestions?
  2. maine-e-axe

    maine-e-axe Junior Member

    Is the switch on the dash on?
  3. TripleJ

    TripleJ Senior Member


    What are you referring to when you say "running lights"? The (2) larger clear lights adjacent to the headlight are called passing lights in the manual and have a toggle switch that maine-e-axe is referring to in his thread that turn these lights on and off and is on the back side of the fork tins on the clutch side.

    If you are calling the amber lights that are also the turn signals the "running lights", it is possible that like Tank says, one of the dual filaments may be burnt out or someone has change these bulbs to a single filament bulb which would then only light up as turn signals or running lights.

    While doubtful that both bulbs have the filament burnt out/broken at the same time, it is possible, but I would think it more likely that you have another problem.

    How did you check the fuse? Pulling the fuse and looking at it can lead one to think it is good but checking it with a test light on DVOM will tell the whole story. Check both sides of the fuse to see if you have power with either the test light or meter. If no light/meter is available you could replace the fuse with a new one of the same size and see if that fixes the problem. The next step would be to check the power to the T/S bulbs in the same manner. You could always pull a bulb from the rear light if no light/meter is available for testing.

    I believe you will find it to be either the fuse is bad or you have a wiring issue to track down if it is not one of the things referred to by the other members in their post. Good luck.