Rubber Muffler Hangers Keep Working Out

Discussion in 'Engine, Fuel and Exhaust' started by RibEye, Apr 9, 2011.

  1. RibEye

    RibEye Junior Member

    980
    48
    51
    The rubber inserts in the mufler hangers on my '03 RKC keep working their way out. Is this common? If I put in new ones, would they stay, or do I need to secure them some way?

    Enjoy,
    Rich P
     
  2. Poser

    Poser Member

    21
    0
    0
    Never experienced them working their way out but they are just a few bucks give it a try.
     
  3. Iceman24

    Iceman24 Well-Known Member

    3,234
    48
    13
    RibEye; they're probably worn - time to replace.
     
  4. Jack Klarich

    Jack Klarich Guest

    Agree here and add some silicone lube to the rubbers then they will not squeak and last longer as the silicone will keep the rubber lubed:s
     
  5. HOLY DIVER

    HOLY DIVER Junior Member

    430
    0
    2
    i agree replace them.lube them.....no more problems...i used dow corning 111 silicone lube
     
  6. RibEye

    RibEye Junior Member

    980
    48
    51
    Thank you gentlemen. I have a new set, to go along with my complete redoing of my exhaust system installation (seals, retaining rings, torca clamps, hanger rubber inserts). I will install them when I go in to check my cam chain tensioners (within a the next few weeks). That will be another area of the scoot I will know has been done right.

    For now, I just fed the inserts back in and used a little safety wire to retain them. I only have a part of Sundays to do work on the scoot, so that will have to do for now...

    Enjoy,
    Rich P
     
  7. Jack Klarich

    Jack Klarich Guest

    Sounds like a solid plan let us know how it turns out:)
     
  8. fisherman124

    fisherman124 Active Member

    293
    0
    1
    sounds like they are split , shouldnt work there way out
     
  9. ultrat

    ultrat Senior Member Contributor

    1,315
    0
    1
    I found w/ monster os the metal bar that slides into the rubber is thicker & it pulled mine out of the holder on rt side. Any one that runs M/Os id check um once & awhile...