RoadKing Start Problem 2007 FLHRI

Discussion in 'Engine, Fuel and Exhaust' started by jbabk, Nov 18, 2012.

  1. jbabk

    jbabk Member Contributor

    55
    18
    1
    My 2007 RoadKing spits and backfires when starting hot. I have had this happen a little in the past but never thought anything of it but now its happening more often. I'd like to nip it in the bud before any real problems occur. The bike only has 24000 miles on it. Anybody have any suggestions for me to try? I sure would appreciate it.
     
  2. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    Can you tell us about any mods to the engine?
     
  3. jbabk

    jbabk Member Contributor

    55
    18
    1
    No codes are shown. In answer to your question, it does settle down and run perfectly normal after it starts. As far as Modifications to the engine there really hasn't been any recently but I do have a Dobeck Performance TFI. Its been on the bike for at least two years with no problems.
     
  4. Checkers

    Checkers Member

    29
    0
    0
    I would clean and tighten battery cables. Bypass the tuner and run without it and see if it changes. I would install about 4 oz of Chevron Techron fuel system cleaner, run it hard down the hwy. I would install a new pair of stock Harley spark plugs. At idle, lightly spray some WD 40 between the cylinders and note if RPM's change, may have a vacum leak.
     
  5. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    To take the TFI out of the equation,,,,,Just remove the Ground wire from it...

    With ground wire removed from ground, the TFI is OFF and the Harley will resort to HD's stock injector metering... Nothing else needs to be done to the FI...

    That is the easy way to check IF it would be the TFI... I doubt it to be that...:D

    Your not holding the throttle open a little are you when you start it?

    signed....BUBBIE