Riding Again

Discussion in 'New Member Introduction' started by Snowshark19, Aug 19, 2013.

  1. Snowshark19

    Snowshark19 New Member

    2
    0
    0
    After riding a rice burner 20 years ago I have moved up to a 95 Classic. already pit on 1000 miles in the first month. Having issues already. 73000 miles bike will not downshift unless I rev the engine. Upshift okay while riding. Kinda scary at 65 MPH. Any help would be appreciated.
     
  2. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,516
    133
    215
  3. Jack Klarich

    Jack Klarich Guest

    Welcome to The Forum
    :wt
     
  4. cortezc

    cortezc Member

    46
    0
    0
    Welcome to the forum,,,hope you can resolve your problem. I have read a lot of similar situations but don't know any fix all situation solution...good luck...
     
  5. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,645
    133
    244
    Welcome to the forum

    Brian
     
  6. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    4,387
    103
    404
    :woe From Colorado.
     
  7. SledDog

    SledDog Senior Member Staff Member Moderator

    2,062
    68
    76
    Welcome!
     
  8. tourbox

    tourbox Senior Member

    1,742
    83
    135
    Welcome from So. Texas
    tourbox
     
  9. dbmg

    dbmg Experienced Member

    5,800
    153
    321
    Welcome to the "BEST on the NET" and Howdy from Pa. :s
     
  10. Joyflyin

    Joyflyin Experienced Member Staff Member Moderator

    5,628
    133
    151
    Welcome aboard, glad to have you here. :ws