Rewiring battery and alarm on Sportster 2007

Discussion in 'Electrical' started by Phil Evans, Feb 17, 2011.

  1. Phil Evans

    Phil Evans New Member

    1
    0
    0
    Hi. I took my battery off last November when I stored the bike away over winter. Last week I charged it up and put it back on, thinking everything would be fine and dandy. Well, I must have done something wrong somewhere, because I can't get the thing back up and running!
    Firstly,I wired up the 3 cables marked in red to the +, and 2 marked in black to the -. Was this correct?
    Secondly, what is the procedure for re-setting the alarm? I've looked on line and I seem to be getting conflicting advice (press both indicators twice, press the left then the right, stand on one leg and whistle etc etc). I know the code, if that helps.

    Please, any advice on this would be great. I'm not a mechanic, but I'm surprised such a simple thing like this has caused me such a problem.
    Thanks
     
  2. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Meaning what?
    No lights, has lights but will not crank, or has lights,cranks and will not start? Do you have Factory security system with FOB? HandsFree?
     
  3. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    Since 2007 Sportster was first year of keyless fobs, if you turned on the ignition, then pulled the Maxi-fuse the alarm would not activate, deafen you (if you have Security Audible Alarm). If you just pulled the battery cable off, the alarm activated presuming you are not the owner of the bike. The manual alarm deactivation sequence is described in the Self Help section...and in your owners manual. Just read thru the procedure so you can watch the flashing indicator and proceed with each step. You do not want to delay or rush the procedure, else you will have to start again.:s