Replaced Cobra FI2000 with TFI Gen3

Discussion in 'TFI Settings' started by iamdent, Oct 18, 2011.

  1. iamdent

    iamdent Member

    48
    0
    1
    When I bought my 06 EGC the previous owner had installed a Cobra FI2000, problem with it was if you set the unit per Cobra tuning settings if would throw a constant engine alarm code. I don't remember the exact code number but it was basically saying the injectors were staying on to long. The only way to clear the code was to turn the green pot completely off. The bike ran fine but I never did feel comfortable with that engine light being on all the time. After installing slip on Rhineharts I got quite a bit of decel popping and never could tune it out, then I bought Vance and Hines Duke air filter kit. Due to my mistrust of the Cobra I did not put it on until I got on the phone with Chris at Dolbeck and ordered my Gen3. Chris was great help, when I started telling him about having the Cobra unit he asked was I getting a code before I even told him, ha, guess it's a common problem.

    After installing the Gen3, which was very simple, I took a 100 mile poker run on the bike. Wow, I could tell a major difference in throttle response, accell, improved fuel millage (I will post that difference after I've ridden enough to get a true measurement). Anyway needless to say I am a very satisfied customer, absolutely the best $200 bucks I've spent on the bike.
     
  2. coopernicus

    coopernicus Junior Member Contributor

    583
    48
    58
    installed my first gen 3 last week. improvements noticed so far. Smoother running, absolutely no decel popping, quicker acceleration and no in between shift farts. seems to be using a little more fuel but that is to b e expected. I will post my fuel mileage on three tanks when I run through them. My initial settings are G. 3.5 Y. 3 R. 3 GB. 2 YB. 4 RB 4.5. These are the settings that were on it when I got it. :newsmile01:
     
  3. coopernicus

    coopernicus Junior Member Contributor

    583
    48
    58
    first tank mileage is at 39.47 mpg. Before gen 3 was around 42 mpg. post next tank later
     
  4. coopernicus

    coopernicus Junior Member Contributor

    583
    48
    58
    ps. don't go by the pic of bike. I now have arlen ness inverted big sucker on the bike ..will post pics later.
     
  5. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,596
    103
    296
    You'll notice a drop in mileage, what you quoted is within the norm. I believe your green mode has the biggest effect on your mileage.
     
  6. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    What I have found is that when a positive improvement has been made to the performance of bike, you tend to run a little harder which of course uses more fuel.....:s
     
  7. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    I have found that the settings (1 & 2) CAN be tweaked Down JUST a little BUT you are Right in the BallPark...

    I'd rather have the engine running Cool from More fuel than go the other way Lean to run too Hot.

    Check your exhaust ends for blk carbon and plugs in a couple hundred miles to see IF it is OKAY...:s

    signed....BUBBIE
     
  8. coopernicus

    coopernicus Junior Member Contributor

    583
    48
    58
    Jeff, that is just what I expected and it is ok with me. I have zero complaints with the gen 3.
     
  9. coopernicus

    coopernicus Junior Member Contributor

    583
    48
    58
    yeppers.....and I must say that I am quite enjoying myself. I tend to run higher rpms now so I can hear her sing...:D
     
  10. coopernicus

    coopernicus Junior Member Contributor

    583
    48
    58
    I agree 100%