rejeted the carburtor

Discussion in 'Engine, Fuel and Exhaust' started by sportyXL06, Mar 12, 2009.

  1. sportyXL06

    sportyXL06 Member

    60
    16
    0
    I installed vance and hines exhaust system on my 06 1200 sporty and I also changed the pilot and main jet . the bike runs great but after you ride it for a long time and come to a stop . The engine Idle stays up above normal and remains there for about 45 seconds before retuning to its normal idle speed any Ideas of what could be causing this!
    thanks
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Have you checked the throttle cables for binding or lubrication.
     
  3. kemo

    kemo R.I.P

    1,690
    48
    5
    The accelerator pump should not make the idle stay up. The pump only gives a shot of fuel and then its job is done.
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    The accel pump has been known to cause a problem if the linkage is not reinstalled properly.
     
  5. sportyXL06

    sportyXL06 Member

    60
    16
    0
    Okay today I lubed the cables and I also checked the excelerator pump linkage and lubed it too and I slid the shaft boot up and I put a little wd40 on the shaft , I also made sure the throttle cables were adjusted to the specification recomended by harley.
    I rode the the motorcycle to and from work and I had no problems with erratic throttle
    so far! I will ride it some more to make sure but I think it's fixed

    thanks guys sporty