Radio Works but Dosen't Work

Discussion in 'Touring Models' started by SteveGleckner, Mar 11, 2016.

  1. SteveGleckner

    SteveGleckner Member


    I just purchased a 2005 Ultra Classic. Love it so far but I have a problem with the radio. When it is cold after sitting overnight it works fine. After I ride it 10 minutes or so none of the buttons work. It still plays the station I selected when it was cold but nothing else works. I can't adjust the volume, change stations or mode or even turn it off with the power on/off button. Turning on and off the key does not fix anything ... I need to wait until the next morning when it is cold then it works fine.

    Has anyone had this problem ... if so what did you do to get it fixed. Can anyone recommend any repair shops other than the dealer.


  2. craig Lee

    craig Lee Active Member

    Hi Steve, I have a 2008 SG (90,000 miles) and presently on my 3rd radio (Harmen Karden). Not sure what make your radio is in the 2005 (the guru's will chime in) but my 3rd radio has been having problems and I've given up. :) (the led goes out but I can still power, play and change channels, go figure) I think with all the vibrations, etc. cold solders appear and it's going to be an unending battle with a radio on a Harley. The best to You and you're not alone with the radio gig. You're definitely on the correct forum for answers and directions.
  3. Rod Stewart

    Rod Stewart Active Member

    Your radio wont be covered by warranty, but you should probably should find out where Harley sends their radios for warranty repair, and maybe they have an exchange program or something similar.
    Another thought is a used one off ebay.
  4. dbmg

    dbmg Experienced Member

  5. Breeze3at

    Breeze3at Well-Known Member

    I believe your radio is made my Radio Sound Inc. Louisville, KY. Maybe they can help.
  6. glasspilot

    glasspilot Member

    The HK radio in yours and my bike (06 Ultra) is a good one but it has one quirk, which I found out from another poster. If you take it out and look at it you will find the front is clipped on the rest of the unit. If it has many miles on it, you will find the front section "wiggles" a little. This will cause the electrical connection between the front and the back to be intermittent. After you take the front off and clean it, clip the front back on. What I did, to tighten up the connection, was to use some strong stranded packing tape and tighten up the front so there is no more "wiggle". I used 1 inch pieces all around the front to the rear. These are not visible when the radio is mounted in the fairing.

    Ever since I did this I have had no more electrical glitches with my radio.
    craig Lee and HDDon like this.
  7. joel

    joel Junior Member

    I read that Iron Cross in California is a good place for repairs and they give a 1 yrs warranty
  8. 89 FXRS

    89 FXRS Active Member

    2006 and up is the Hamon Kardon, 2005 and older head units are Radio Sound, Iron cross does repairs on the HK units