radio shack siren

Discussion in 'Touring Models' started by razor10, Mar 23, 2011.

  1. razor10

    razor10 Member

    16
    0
    0
    recently tried installing the radio shack siren on my 02 ultra when i set the alarm get a short buzz sound and when i shake it i get 1 short blast from the siren wondering has anyone did this install on a 02 ultra and ifso did it work
     
  2. Hoople

    Hoople Account Removed

    7,198
    0
    34
    When you shake the siren itself you get a short blast? That should not be. Did you happen to test the siren itself before installing it by clipping it across a battery just to see if it blows? Almost sounds like a defective siren module or bad connection to the HD wiring harness..
     
  3. razor10

    razor10 Member

    16
    0
    0
    siren works fine i actually have 2 sirens both function properly when i shake the bike i get 1 short blast
     
  4. Redfish-Joe

    Redfish-Joe Senior Member

    2,307
    48
    10
    Did it on my 08 and my buds 09. no problems.
     
  5. nvsteve

    nvsteve Member

    76
    0
    0
    I've had them on 2 bikes and they work fine.
    Are you sure you have the wires in correctly? If installed wrong something similar to what you posted can happen.
     
  6. razor10

    razor10 Member

    16
    0
    0
    yeah red to brown and black to green my brother-in-law tried it on his 04 road glide has the same problem does the security system have to be set in a ceartain mode
     
  7. lorne

    lorne Senior Member

    2,426
    58
    18
    loose ground???