Radio Problems

Discussion in 'Communications And Radio' started by 455gto, Jun 8, 2011.

  1. 455gto

    455gto Member

    8
    11
    0
    Looking for something to look for, I replaced my inner fairing on my 07 RG. Looked pretty strait forward, however when I went to test every thing before replacing the outer shell the radio does not work. I've checked all the connections including antenna and speakers but nothing, next I am going to check fuses (decided to walk away last night before a higher level of frustration set in). The only other thing I can think of is there a reset procedure after taking the radio out?
     
  2. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    68
    100
    No reset. But make sure the fuse is not blown and the gang plugs are all the way seated.

    TQ
     
  3. JBC2565

    JBC2565 Junior Member

    582
    28
    2
    Did you disconnect battery before taking radio out? Connections back on tight and clean?
    Check the ground wire?
    Hoping you just have a blown fuse.
     
  4. wannaride

    wannaride Active Member

    259
    28
    2
    Mine did the same thing. Mine is a 1999 UC & I checked the manual, it showed how to pull codes & I was surprised how much that helped. Found a brn/blk wire shorted to ground, pulled it out of the connection & the radio works now. It was audio input wire & some day I will look for the short.

    Toby
     
  5. 455gto

    455gto Member

    8
    11
    0
    Hey thx for all the help it ended up being a fuse, but it was time to quit the other night any way again thx for the help!
     
  6. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    68
    100
    Great!

    Ride on.

    TQ