Radio cuts out

Discussion in 'Touring Models' started by glen073, Oct 19, 2010.

  1. glen073

    glen073 Active Member

    176
    26
    0
    Just developed a problem on my 2010 Ultra. While riding along listening to the stereo, it will cut right off. You still see the display on the radio screen. Then if I toggle the switch for the speakers in to either the middle posistion of the down position, it will come back on, but the problem will occurr again. Sometimes in a minute or two, or it could go several hours.Turning the radio off and back on it will also get it to come back on.

    This was the case until tonight. When it cut off, I could not get it to come back on trying any of the things above, however it worked through the head set. Just when I was about to give up, I toggled the switch down and it worked again.

    I just talked to another owner of an 09 Ultra the other day and he said his did the same thing just before I quit working all together. I was wondering if any others have expirenced this problem. I'm contacting my local dealer about the problem tomorrow.
     
  2. Lancer

    Lancer Junior Member

    495
    28
    2
    I had a similar issue, it was a short in the wiring harness. I could hear it through the helmet speakers but not through the fairing speakers.
    _
     
  3. lasvegasrick

    lasvegasrick Member

    13
    0
    0
    my radio is cutting out ,i am on my 4th one,its the amp transistor they crack at the solder joints...yours needs to be replaced...good luck my bike is 06 ultra
     
  4. jimbohand

    jimbohand New Member

    3
    0
    0
    my wifes 06 road glide was just the speaker switch, went bad
     
  5. glen073

    glen073 Active Member

    176
    26
    0
    They replace the amp tranistor or is it a whole new radio? Bike goes in next Wednesday for the warranty on it. I will mention what you said.
     
  6. mca1989

    mca1989 Member

    22
    11
    0
    my CD has stopped playing it shows CD mode but no music