Radio Blues

Discussion in 'Touring Models' started by ReefRider, Mar 21, 2010.

  1. ReefRider

    ReefRider Member

    29
    1
    0
    I went to go out for a ride and decided I would take along my ipod nano that was loaded with blues music. I started the bike and noticed I had no display on the radio. The radio plays fine just no display. I stopped by the local shop because I read in the self help section that they HD radios you could send off for repair for a flat fee for in the 200 and something dollar range. Service at the local shope quoated me $450 flat rate if I remove the radio. They said they also needed the vin# and something else off the bike...I didn't hear the rest as I was thinking $450, $450, $450,$450.....Does this sound right? Anybody else seen this problem and am I missing an easy fix? Is the an after market that fits and works with all our controls? Now I really have the blues.......
     
  2. khewell

    khewell Member

    97
    0
    0
    Mine use to lose the display every now and then. After i painted the inner fairing and disconnected the wires it hasn't done it.
    Also seems like I remember seeing a post on the radio that said maybe down loading the latest download for it might fix it.
     
  3. Iceman24

    Iceman24 Well-Known Member

    3,224
    48
    13
    Also, might not hurt to pull the fairing off & check wiring harnesses. Something could've come loose & then you can also determine if an aftermarket system will fit. Do a quick check on eBay for used systems for your year too...could be cheaper than going w/the dealer fix option @ $450.
     
  4. lionsm53

    lionsm53 Banned

    122
    0
    0
    Does the IPOD work then?
     
  5. ironmark

    ironmark Junior Member

    754
    28
    4
    Your display light fader may be adjusted to far , take the audio switch on the left side control & make sure it is set on volume by playing the radio then take the audio switch and push it 4 times that should take you to the dispay mode then move the audio switch up or down that may bring back the display if that does not work try dissconnecting the battery for a while and then reconnect that may reset the radio .
     
  6. Redfish-Joe

    Redfish-Joe Senior Member

    2,307
    48
    10
    Just had mine replaced for the same thing for the second time. In the meantime you can try this. Take two fingers and lightly press in on your display. The display should come back on. Not a permanent fix but should help. This worked for me. Good luck!
     
  7. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
  8. Redfish-Joe

    Redfish-Joe Senior Member

    2,307
    48
    10
  9. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    Joe, you did the only reasonable thing one can do given the circumstances because everything IS working okay and you do not want to go in with likelyhood of more damage than good. In the old days manufactorers used connectors or spring fingers to engage the fine pitch connections on the display and make it serviceable (when displays were expensive).

    Nowadays with "disposible" electronics, it is likely that display is soldered into a mother board making it prohibitive to "just replace one thing". That is why even one who is into microelectronics slowly backs away from getting at that $15 display (if you go to DigiKey or other suppliers) on the rare chance that it is the part...the difficulty and potential for peripheral damage is usually beyond the scope of most DIYers.
     
  10. marty

    marty Member

    53
    18
    1
    i would call ironcross audio!they are hk service center and while they have it you can change color of display if you are thinking of changing gauge color!! the are super nice people talked to them friday about color change on a 01 thay say it is coming soom they just do 06 and up for now !!