Power Loss - 2007 FLSTN

Discussion in 'Softail Models' started by Bosbury1, Sep 19, 2010.

  1. Bosbury1

    Bosbury1 Active Member

    138
    26
    0
    When I start my bike and go to take off I turn the throttle and the bike hesitates for a moment. This does not happen all the time it seems to happen more when its initially started. Replaced the plugs, pulled the air cleaner off (cleaned and oiled). Placed Lucas Injector treatment in the tank no help. Also, Pulled the codes got the P131 & P151 codes, cleared and as of today no new codes for the past 10 days or so. Any thoughts?
     
  2. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Was it running fine and it just started doing this? What's the mileage on the bike. Are you running a piggy controller. What changes (if any) have you made to the bike since the time this problem started. Has the idle RPM been erratic. Once the engine warms up does the problem go away. Stage 1 hardware or bone stock.
     
  3. Bosbury1

    Bosbury1 Active Member

    138
    26
    0
    15K; Stage 1; SERT with Dyno; no changes before or after this problem. When it warms up it seems to lose the the hesitation, but still runs poorly.
     
  4. Hoople

    Hoople Account Removed

    7,198
    0
    34
    P0131 (lean) & P0151 (lean), running SERT, hesitation from off idle, no piggy, 3 year old bike, 15K, no other error codes, my very first thing to check would be fuel pressure. Bet it is low.
     
  5. Bosbury1

    Bosbury1 Active Member

    138
    26
    0
    Today, when I turned the bike on you can hear the fuel pump electrical and was wondering if that could be it. How do I check the pressure?
     
  6. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Requires a special adapter (HD-44061) and a gauge. Setup will run you $75. No other easy way to do it that I can see. Service manual goes into detail on how to check. This adapter/setup lets you run the bike while checking pressure under dynamic conditions.

    You can have the "pinhole" hose problem inside tank also (hissing noise). Do a search and you will find info. This will result in low pressure also.
     
  7. Bosbury1

    Bosbury1 Active Member

    138
    26
    0
    Thanks will do.

    Pulled out the tank fuel pump and assembly looks like the hose maybe weak in the creases. The design seems strange like a flexible straw like my kids use to have. Well need to replace both hoses should I get the HD replacement or go with a traditional black submersible fuel line at the parts store? Also, replace the fuel filter or go with the same one? Are regular small hose claps acceptable? Thanks
     
    Last edited by a moderator: Sep 22, 2010
  8. Hoople

    Hoople Account Removed

    7,198
    0
    34
    If it was me, I would go for the Harley Genuine replacement parts along with a new filter. You probably can get away with SS worm clamps.

    The service manual says to replace the gasket and screws also.. At least on my bike it does. The screws have special o rings in them.
     
  9. Bosbury1

    Bosbury1 Active Member

    138
    26
    0
    Any ideas for cleaning the fuel pickup screen?

    Replaced both hoses in the tank same problem. Any other ideas?
     
    Last edited by a moderator: Sep 22, 2010
  10. Hoople

    Hoople Account Removed

    7,198
    0
    34
    You can guess & try a bunch of things but I could not move on or forward without 1st knowing what that fuel pressure was.

    Others may jump in with other suggestions. You have not answered entry point #2 question. Is idle erratic.