popping on Deluxe

Discussion in 'Engine, Fuel and Exhaust' started by twicecam, Jun 7, 2008.

  1. twicecam

    twicecam Active Member

    241
    26
    0
    I have a 2006 Deluxe with stage one and 2000 miles since I replaced the stock HD plugs with autolite plugs, I've always had a small amount of dcell but now I have more hesitation when it is cold and some popping under low acceleration and when I'm cruising at 30-40 miles per hour a intermintant popping. After I get on the highway and it warms up real good it does clear up, but if I park it for 45 minutes or so and get back on it's the same routine, I have never used fuel injector cleaner because I haven't figured out the ratio of cleaner to gas. I have been going through alot of the threads and there is alot of possibilities, where to start??? Spark plugs, intake leak, injectors, I need input where do I start first? Almost forgot, the bike has 18,000 miles on it.
     
  2. glider

    glider Veteran Member

    25,464
    108
    43
    I would start with a set of HD plugs and check the resistance in the wires or replace them, they are cheap enough and it sounds like you could have an ignition problem, especially if you didn't handle the wires easy when you removed them. As far as the injector cleaner, a ounce or so should be about right for a full tank but the fuels today have cleaners in them.
    Did you gap the plugs when you put them in?

    Any codes set?
     
  3. twicecam

    twicecam Active Member

    241
    26
    0
    I set the plugs at HD gap How do you check codes?
     
  4. Doc 1

    Doc 1 Member

    51
    18
    1
    Using anything else but Harley plugs in the Delphi EFI system is asking for trouble.....the Ion sensor can be wacked out because of the resistence change in the plugs and the ECM will start pulling timing out of the map for no reason causing miss fires andthat can cause excessive fuel in the pipe to pop on you.
    It's important to stick with stock plug wires and stock plugs....you gain NOTHING from Auto Lite plugs.
     
  5. glider

    glider Veteran Member

    25,464
    108
    43
  6. twicecam

    twicecam Active Member

    241
    26
    0
    Just got back from the dealer, got new plugs and wires. Live and Learn. Thanks doc, thanks Glider. I guess there are just some things you can't substitute for aftermarket, I'll let you know how it comes out.:bigsmiley12:
     
  7. glider

    glider Veteran Member

    25,464
    108
    43
    Well there ya go now, problem solved. Glad it's fixed.
     
  8. twicecam

    twicecam Active Member

    241
    26
    0
    Idles good ,runs good ,problem solved. I still have intermittent popping on decel, I have vance and hines long shots staggered..it's done that since I put them on.:yes
     
  9. Doc 1

    Doc 1 Member

    51
    18
    1
    Are you running a SERT? If so I can help you get rid of that popping in a heart beat!!!
     
  10. twicecam

    twicecam Active Member

    241
    26
    0
    :DAlmost forgot no codes came up :D