Play in shifter linkage....

Discussion in 'Touring Models' started by lakeforktx, Jan 9, 2012.

  1. lakeforktx

    lakeforktx Active Member

    229
    0
    2
    my 04 Eg is loose down on the spline where the one bolt tighens up on the arm...remember seeing some differnt fixes and a bolt replacement upgrade,, can't seem to find it...thanks for helping.........
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
  3. lakeforktx

    lakeforktx Active Member

    229
    0
    2
    Thanks Glider will be looking into doing something in the future...hopeing I could just tighten it up and get by for awhile ?,,
     
  4. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,316
    73
    130
    I had the same issue. You can try replacing the bolt but most likely it is the splines on the shift arm itself that are worn. Hopefully and if you let it go to long the shift arm itself is worn. The shift arm is a bigger project by far. The Better Lever wasnt around when I did mine. I purchased a new shift arm, gasket kit and pulled the primary off and replaced the arm and bolt. I have never done a Better Lever but seems to me that it probably doesn't save that much time. If your shift shaft is worn, the Better Lever may clamp better than stock and prolong the agony. I have heard of cutting a piece of beer can out and wrapping around the shift shaft to take up space of the worn part.
    Let us know what you decide and how it goes.
     
  5. skeeter114

    skeeter114 Member

    18
    0
    0
    My 04EG had the same problem, the splines on shifter arm were worn so it had to be replaced.
     
  6. dd1228

    dd1228 Active Member

    125
    0
    0
    Same problem on my 02 FLHTC. I replaced the shifter arm with an after market good looking chrome thing I bought on ebay and it tightened right up. But now a month or so later it has the play in it again. So I suppose it's the shaft that is worn and will eventually need replacing.
     
  7. glider

    glider Veteran Member

    25,464
    108
    44

    One thing you could try is removing the shoulder bolt that is in the arm now and replacing it with a longer grade 8 bolt without a shoulder and then nut the end where it comes through the arm and snug it down. It usually tightens it up. Usually the problem is in the softer metal of the arm itself with the splines wearing and not the shaft.

    Don't over tighten the nut and new bolt or you can crack the arm.
     
  8. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    I know that on my 08 EG mine was loose also. I was lucky and did not have to replace bolt.
    Glider's recomendation is where I would start first, and do not be afraid to properly torque down on bolt....:s