Pin connectors (Molex or Deutsch)

Discussion in 'Touring Models' started by Biffy08, Mar 10, 2012.

  1. Biffy08

    Biffy08 Active Member

    230
    36
    0
    Does anyone have advice on how to reassemble the Molex or Deutsch (not sure which one) connectors of the handlebars controls on a 08 Ultra?
     
  2. Iceman24

    Iceman24 Well-Known Member

    3,224
    48
    13
    Are you talking about removing the pins from your wiring harness..?? If so - the service manual has good pics in back. There's a tiny catch you need to hit with a pin/tool. I used thick/lg paperclip & it worked fine & took alot of pics to ensure I got the wires back in correct terminal slots.
     
  3. Biffy08

    Biffy08 Active Member

    230
    36
    0
    Thanks Iceman24.:)
    I should have specified further. I was able to disconnect at the same time knowing where each pin color goes. My problem is reassembling the plug - getting the pins back into the housing, getting them in straight, and without moving them out of their locked position.
    :wall
     
  4. glimmerman

    glimmerman Active Member

    354
    28
    1
    the deutsch connectors have a screw driver type tool that pulls the lock out of the connector. then the connector will come apart and the tool is used to press out the pins. they should snap back into the connector. then the pieces are pressed together and the lock wedge pressed into place. all deutsch fittings and tools can be purchased from a company called Ladd Industries. prices are about 1/3 of what H-D charges. bought the tool to put ends on as well. sales lady tossed in the lock tool and something else for free.
     
  5. R_W_B

    R_W_B Senior Member

    2,425
    0
    23
    Can you post up a pic of the connectors and/or pins you are having a problem with ? I've done the molex several times, the duetsch are not hard but have a slightly different implementation.
     
  6. Iceman24

    Iceman24 Well-Known Member

    3,224
    48
    13
    This might help...
     

    Attached Files:

    Last edited: Mar 10, 2012
  7. R_W_B

    R_W_B Senior Member

    2,425
    0
    23
    Thanks Iceman but those are AMPS connectors. Usually those are for the sigs wires only. The main switch group runs from either Deutcsh or Molex.

    I will go ahead with the molex first since I got a hunch those are what he is having trouble with. If they are Duetsch then he will not recognize the following.

    Biffy if you are the one that pulled them apart, after you initially separated the two connector sections (male and female), then you would have had to grab the center hole in the recessed plastic plate and pull up (or out) on it about 3/16 of an inch travel. I use small needle nose pliers when I do mine. Some folks hook the hole with a curved pic tool.

    After you get the wire pins back in you will need to press this plate back in before you assemble the two sections back together.

    As far as the pins they will only go in one way properly. You will know something is wrong if they are not the right way. If I remember correctly you turn the crimp side toward the connector housing (instead of away from it). BTW it's the same scenario with the AMPs if you are having trouble with them also.

    Once you start in with pin make sure it stays straight since the wire will sometimes try to twist the pin as you go in.
     
  8. Biffy08

    Biffy08 Active Member

    230
    36
    0
    Thanks to all. My brother, a good friend of mine and I finally got it all back together and bike is back on the road as of yesterday. I will have to say that age old line, you are only as good as your tools. We had to have the right tools for reassembly of any of the connectors that I or you have described. It took us 3 weekends, we learned a lot:newsmile077:, but in the end it was worth it because of the personal satisfaction and the $$$$$$ savings. It really was time consuming but again, worth the time! Thanks everyone for your help!:D