passing light not working

Discussion in 'Electrical' started by ROOT BEER KING, Feb 18, 2012.

  1. RUSHMORE_14

    RUSHMORE_14 Junior Member

    538
    28
    1
    Ok, I changed out the lenses from stock to smoked. Also changed bulbs from clear to amber. They all worl except the right side front. Even when I put the original bulb back in, it didnt work. Should I just try another bulb ...is there a specific bulb I should be putting ing there?
    Dont know what direction to go.
     
  2. Nickster

    Nickster Member

    22
    0
    0
    double check all wire connections, maybe you accidentaly pulled one out somewhere?
     
  3. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    See if by exchanging assembly that the ground is no longer grounded at right socket. And also check prongs in socket that they are making proper contact to bulb.
     
  4. RUSHMORE_14

    RUSHMORE_14 Junior Member

    538
    28
    1
    the light works, but doesnt blink. Its either on all the time, bright, or not at all.
     
  5. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    It is possible that aftermarket bulbs can be install incorrectly and it can happen easily or the bulb is not manufactured properly . It will sometimes distort socket so that contact hits wrong place and is light is lit all the time... Might be why the OE bulb is not working properly also... Usually spring loaded contacts at base of socket get hung up and touches both prongs on bulb....
     
  6. Mongo1958

    Mongo1958 Junior Member

    720
    28
    18
    At this point I'd use a volt/ohm meter to find out if there is power and ground getting to the lamp and to ohm out the bulb to see if it's good.
    If you have power and ground getting the lamp then you may have a defective bulb. If the bulb ohms out OK then I'd look at the connector to see if there is an issue with the pins or wiring. If you don't have a Volt/Ohm meter then get one. It will come in handy foe many other projects as well.
     
  7. RUSHMORE_14

    RUSHMORE_14 Junior Member

    538
    28
    1
    Works. In my idiocy, I simply put the bulbs in the wrong way.
     
  8. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    Don't feel bad, it can happen to anyone. Glad you found the problem.