P0505 loss of idle control

Discussion in 'Touring Models' started by ducman38, Apr 3, 2010.

  1. ducman38

    ducman38 Member

    8
    0
    0
    I have a 2005 Screamin eagle ultra with a 113 inch engine. I have a problem
    that just started, P0505 code lossof idle control. my bike is idleing about 1500 to 1700 rpm's I checked the idle control motor and it is working. I can also see that while it idles the motor runs the needle end all the way down in the bore, like it is trying to slow it down. does anyone have any ideas.
     
  2. cdn-bigfoot

    cdn-bigfoot Junior Member

    645
    26
    1
    Ensure your IAC (Idle Air Control) plug is connected properly. See your service manual for location on your model. It should be above the air intake on your throttle body. It is a 4 connector waterproof plug.
     
  3. rancid

    rancid Active Member

    257
    28
    1
    sounds like you might have an air leak id be looking at that first
     
  4. Joe2007ultra

    Joe2007ultra Active Member

    184
    26
    0
    I agree with rancid, Spray the intake area with wd40 if you see smoke at the exhaust you have a leak . Try and spray the intake gasket area that is usually the culprit
     
  5. ducman38

    ducman38 Member

    8
    0
    0
    I used propane and then went to WD40 went all around intake area did not notice any change in rpm, what do i do next?
     
  6. ducman38

    ducman38 Member

    8
    0
    0
    I found the problem tonight, the throttle bodie screw came loose that is normally factory sealed and backed out causing the high idle. Thanks everyone for the help.
     
  7. Joe2007ultra

    Joe2007ultra Active Member

    184
    26
    0
    Glad you found it ! Lock Tite that thing in!!!