Over voltage codes when wet

Discussion in 'Electrical' started by airdrie, Sep 26, 2010.

  1. airdrie

    airdrie Member

    62
    18
    1
    A few weeks back I took off for the weekend doing a scoot from Calgary to Vancouver in a big loop. On the way home it was cold and wet and while riding I noticed the Engine and Battery icons light up on the speedo. There was no other indication anything was amiss but I pulled over and a visual inspection to make sure nothing obvious was wrong. When I restarted the bike, the warnings were gone. Last weekend, I washed the bike and had the same warnings pop up and later disappear. I checked the self help instructions here (invaluable) to check the underlying codes.

    I'm getting the following:

    P0563 - batter voltage high EFI
    B0563 - battery voltage high TSM/TSSM
    B1006 - Accessory line over voltage
    B1007 IGN line over voltage
    U1016 Loss of ICM/ECM Serial Data Instruments
    U1016 Loss of ECM Serial Data, Vehicle Speed, Vehicle Inhibit Motion or Power train Security Status TSM/TSSM

    I took the bike out for a ride on Friday (warm and dry) and there was no indication of problems.

    I'm wondering if this is a problem with water getting into the regulator? Should I check anything else?

    Thanks
    Matt
     
  2. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Would you be starting the bike while a battery charger is still hooked up to the bike?

    Write down the list of error codes you now have. Clear the error log of all codes. Place a hi-quality voltmeter across the battery and check what the charging voltage is at idle and at a steady 3000 RPM. What are the measured voltages. Ride the bike and see if any new voltage codes appear. Don't go by check engine light appearance only. Manually check the error log.

    Once you collect some of the above info, you will be on track as to what is going on.