One side turn signal not blinking

Discussion in 'Electrical' started by ADragon, Oct 3, 2010.

  1. ADragon

    ADragon Member

    11
    1
    0
    I have a 1992 Dyna FXDB, the alternator plug kept popping out and the battery was drained down to the point that the turn signals stopped working. I brought a retaining clip from JP Cycle to make sure that the alternator plug from popping out. However, after the battery was charged back up, only one side signal worked. The other side running light would stayed on but when I activated the turn signal, it would not blink. Can anyone one help me pin point what the problem is so I can get the right part to make the repair. I have checked the signal switch already and it works and I am running out of thing to check.
    Thank you in advance.
     
  2. 2000classic

    2000classic Active Member

    301
    28
    1
    Check the front and rear bulbs on the side that is not working. One of the bulbs may be burned out.:(
     
  3. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,276
    133
    156
    front bulb has 2 filaments a low wattage one for running lights and a high wattage one for the indicator so just because it is on for running lights does not mean it is good

    Brian
     
  4. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Check both contacts with a test light
     
  5. ADragon

    ADragon Member

    11
    1
    0
    Thanks for the information, I will do a swap of the good side with the bad and see if it would tell me more.
     
  6. ADragon

    ADragon Member

    11
    1
    0
    As it turned out, it was the turn signal canceller. One side just would not blink. After over $200 for a new canceller from the local HD dealer, everything is fine now.
     
  7. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Out of all the things it could have been, it turns out to be the most expensive part. That is the way my luck runs...

    Glad your up and running.