Oil spitting from tranny vent?

Discussion in 'Transmission' started by kldrury, Apr 17, 2012.

  1. kldrury

    kldrury Member

    7
    0
    0
    I have a 90 Heritage and just installed a new oil pump. It runs great but I'm getting oil spitting from the tube coming from the motor right beside the oil pump. Never had this problem before. Any help very appreciated!
     
  2. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    83
    101
    Did you open up the nose cone in order to install the new oil pump? If so, you may have mis-timed the breather gear. If this is off you may be exhausting oil out the breather line. You will have to get back in there and align all of the timing marks to retime the engine.

    See figure 3-55 here:

    Harley Davidson Community

    TQ
     
    Last edited: Apr 18, 2012
  3. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,279
    133
    157
    Close to the oil pump on the main crank case is the crank case breather this should not be an open tube but should be plugged into the rear of the air cleaner back plate
    if the air cleaner back plate has been replaced by a later model a filter should be on the end of the breather pipe

    Brian
     
  4. kldrury

    kldrury Member

    7
    0
    0
    That hose was always open and running under the frame. I don't have anything running to the air cleaner. I did open the nose cone so I'll try that now. I'll keep y'all posted...

    And I bet that's it cause being the idiot that I am I pulled the breather gear out just to see what it did!!! no thought to the fact it might be in there a certain way..... Thank you for that file TQuentin1. VERY helpful!!!
     
    Last edited by a moderator: Apr 19, 2012
  5. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    Re reading ALL the above POST, YES it has to align....

    signed....BUBBIE