oil pressure???

Discussion in 'Oil' started by dcofer, Aug 31, 2009.

  1. dcofer

    dcofer Member

    42
    6
    2
    I have a oil pressure issue I hope someone can answer, I have a 1994 electra glide classic ultra and after I ride about 30 miles and let the bike idle the oil pressure drops and the oil light comes on. You can rev it up to about 1200 and the pressure comes back up to about 20lbs but on the road it is fine about 30lbs hot. Any idea what could be the problem here. Don't know what the oil is in it just got the bike about 6 weeks ago but am gonna change it soon probally to red line throughout. Thanks for any info. Dallas
     
  2. twooodogz

    twooodogz Member

    30
    16
    0
    I dont claim to be an avid Motorcycle mechanic but when my car acts like that it is time for a new oil pump.
     
  3. oldhippie

    oldhippie Senior Member

    1,072
    58
    19
    Another possibility is the idle is set too low or sludge buildup (but I'm no mechanic either). I do believe they should be idling around the 1000 rpm range.
     
  4. jel123

    jel123 Active Member

    157
    26
    0
    had the same problem put a new high volume pump in and works great now,jel
     
  5. Breeze3at

    Breeze3at Well-Known Member

    4,645
    83
    124
    Like Oldhippie suggested, look at idle speed first. Lot of guys idle a bike down too low to get the potatoe/potatoe sound. You pressure seems ok at speed. Do the oil & filter change and see how it is at 1,000 rpm, Evo's don't have a lot of pressure at idle, but the light should not come on. Then go looking for bigger problems if it doesn't improve.
     
  6. dcofer

    dcofer Member

    42
    6
    2
    Idle could be an issue here because I do think it idles a bit low I think about 600 rpm's or so. I'll try bringing that up to 1000 and see what it does. Thanks guys for the info.
     
  7. glider

    glider Veteran Member

    25,464
    108
    44
    Standard idle is 950-1050
     
  8. R. Lewis

    R. Lewis Senior Member Retired Moderators

    2,183
    48
    5
    has there been anything done to the bike mod. wise and how many miles on it?
     
  9. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    68
    99
    Dallas,

    Make sure your oil has been changed recently, and that you are using a premium grade FULL synthetic engine oil in your EVO (this does NOT include SYN3). Make sure that you remove and clean the tappet (lifter) block oil screen everytime you change the oil. And make sure that you are using an HD or other premium grade filter that meets the spec for the HD filter.

    See if that helps. If not, pump! or at least rebuilding the one on the side of the nose cone on your engine.

    TQ
     
    Last edited: Aug 31, 2009
  10. dcofer

    dcofer Member

    42
    6
    2
    The bike has no mods to my knowledge to the engine and according to info in the trunk it is in the 2500mile range on the oil change. Plan on changing it real soon. The bike has 53000 miles on it and seems to be a good tight bike and has been taken care of. Had wondered about the spring in the relief valve do they ever get weak when they get hot? I am a pretty good wrench and plan on doing all the work on the bike myself. I have worked on about everything else so don't see that a harley can be that much more complicated. You guys are great and do like other folks opinion on things I am not educated on. not yet anyway:D Dallas